aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fixtures
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 14:03:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 21:06:36 -0300
commit3cb0c5c3d598c11f06e964e5f7e69a082c02262f (patch)
tree6363df9f4d2864c76530267c72e7bce6a37d5a80 /testing/py3-fixtures
parent83cf78a819b468fd95e7b16a54c053cae40c82e0 (diff)
testing/py3-fixtures: drop py2
Diffstat (limited to 'testing/py3-fixtures')
-rw-r--r--testing/py3-fixtures/APKBUILD39
1 files changed, 8 insertions, 31 deletions
diff --git a/testing/py3-fixtures/APKBUILD b/testing/py3-fixtures/APKBUILD
index ef343387bf3..8fb70556253 100644
--- a/testing/py3-fixtures/APKBUILD
+++ b/testing/py3-fixtures/APKBUILD
@@ -1,53 +1,30 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-fixtures
+pkgname=py3-fixtures
_pkgname=fixtures
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Fixtures, reusable state for writing clean tests and more."
url="https://pypi.python.org/pypi/fixtures/"
arch="noarch"
license="MIT"
-depends="python"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-fixtures" # Backwards compatibility
+provides="py-fixtures=$pkgver-r$pkgrel" # Backwards compatibility
+
check() {
- cd "$builddir"
- python2 setup.py check
python3 setup.py check
}
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python" ## remove if arch isn't noarch
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="e52ba864c42d15a8baa60583761006b2dd78e3cd5f3f043f5702346aef428b933d62e8fa5889b7cb4196e4072acc5df3b7ffa39702a1b782887bdc109299b695 fixtures-3.0.0.tar.gz"