aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-libevdev
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-07 03:45:05 -0300
committerTBK <tbk@jjtc.eu>2019-05-25 04:39:52 +0200
commita00094247ff1001181d3282d0f848dc56846e92f (patch)
treedee81e09d98e78fa2f7e5ebe62ed16c4a8ca4b46 /testing/py3-libevdev
parent8b62f5ad03d135d97f6b213311d0687429d5e221 (diff)
testing/py3-libevdev: new aport
Python3 wrapper around the evdev library https://python-libevdev.readthedocs.io/en/latest Closes: GH-7643
Diffstat (limited to 'testing/py3-libevdev')
-rw-r--r--testing/py3-libevdev/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-libevdev/APKBUILD b/testing/py3-libevdev/APKBUILD
new file mode 100644
index 00000000000..cabe04ba46d
--- /dev/null
+++ b/testing/py3-libevdev/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-libevdev
+_pkgname=python-libevdev
+pkgver=0.7
+pkgrel=0
+pkgdesc="Python3 wrapper around the evdev library"
+url="https://python-libevdev.readthedocs.io/en/latest"
+arch="noarch"
+license="MIT"
+depends="libevdev python3"
+checkdepends="py3-pytest"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.freedesktop.org/libevdev/${_pkgname}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH=. pytest-3 test/*.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7ab4bfcb53c0f84735ad5e7fc8c5bde5b164dd3600d7e8c99fdeea1481f75cc177f67ce875ed14ff93cff43d8037cf5c729abc38d2b9b4f2791ad75d5ad50920 py3-libevdev-0.7.tar.gz"