aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-matplotlib/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 12:35:11 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:06:28 -0300
commitb86997d642e9cf948f39a34df74bf08912b6906f (patch)
tree49ba7b5c9ef7a3f1d1e24b2c0720eb73d4c9aec2 /testing/py3-matplotlib/APKBUILD
parent8b01a0261a7c5c92d9309efdbb5bf31fbb4a68e0 (diff)
testing/py3-matplotlib: rename from py-matplotlib
Diffstat (limited to 'testing/py3-matplotlib/APKBUILD')
-rw-r--r--testing/py3-matplotlib/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/testing/py3-matplotlib/APKBUILD b/testing/py3-matplotlib/APKBUILD
new file mode 100644
index 00000000000..ee18fa75fc9
--- /dev/null
+++ b/testing/py3-matplotlib/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: Isaac Dunham <ibid.ag@gmail.com>
+# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
+pkgname=py-matplotlib
+_pkgname=matplotlib
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="A Python library for plots"
+url="https://matplotlib.org"
+arch="all"
+license="custom"
+depends="py-numpy py-dateutil py-parsing py-tz py-cycler py-cairo py-kiwisolver"
+makedepends="python3-dev python2-dev gfortran py-numpy-dev freetype-dev
+ libpng-dev tk-dev py-setuptools py2-backports_functools_lru_cache
+ python2-tkinter python3-tkinter"
+checkdepends="pytest xvfb"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3
+ $pkgname-doc"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/matplotlib/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+# matplotlib provides unit tests, but they need to be run post installation :-(
+options="!check"
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-} python2-tkinter"
+ _py python2
+ # Remove documentation, doc-subpkg will use python3 version
+ rm -rf "$subpkgdir/usr/share"
+}
+
+_py3() {
+ depends="${depends//py-/py3-} python3-tkinter"
+ _py python3
+}
+
+doc() {
+ mkdir -p "${subpkgdir}/usr"
+ mv "${pkgdir}/../py3-$_pkgname/usr/share" "$subpkgdir/usr/"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ cd "$builddir"
+
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+ install -m755 -d "$subpkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE/* "$subpkgdir"/usr/share/licenses/$pkgname/
+}
+
+sha512sums="d118f5d56e2f578031aba22933c0b3a4423a31a04f50f08cc1aa660186546d09692a9cf401bb5f24cb296f94fbfd8707460728d501ac2bd4a624dfa89e92949b matplotlib-2.2.3.tar.gz"