aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-matplotlib
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 12:38:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:06:28 -0300
commit86466ac13658f30038f5dca852ab3e0de2e58978 (patch)
tree15516ae6d893814c39745b2e0dcd8f20c61e3018 /testing/py3-matplotlib
parentb86997d642e9cf948f39a34df74bf08912b6906f (diff)
testing/py3-matplotlib: drop py2
Diffstat (limited to 'testing/py3-matplotlib')
-rw-r--r--testing/py3-matplotlib/APKBUILD55
1 files changed, 12 insertions, 43 deletions
diff --git a/testing/py3-matplotlib/APKBUILD b/testing/py3-matplotlib/APKBUILD
index ee18fa75fc9..8bbaeabd3c1 100644
--- a/testing/py3-matplotlib/APKBUILD
+++ b/testing/py3-matplotlib/APKBUILD
@@ -1,62 +1,31 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
-pkgname=py-matplotlib
+pkgname=py3-matplotlib
_pkgname=matplotlib
pkgver=2.2.3
-pkgrel=1
-pkgdesc="A Python library for plots"
+pkgrel=2
+pkgdesc="Python3 library for plots"
url="https://matplotlib.org"
arch="all"
-license="custom"
-depends="py-numpy py-dateutil py-parsing py-tz py-cycler py-cairo py-kiwisolver"
-makedepends="python3-dev python2-dev gfortran py-numpy-dev freetype-dev
- libpng-dev tk-dev py-setuptools py2-backports_functools_lru_cache
- python2-tkinter python3-tkinter"
-checkdepends="pytest xvfb"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3
- $pkgname-doc"
+license="Python-2.0"
+depends="py3-numpy py3-dateutil py3-parsing py3-tz py3-cycler py3-cairo py3-kiwisolver
+ python3-tkinter"
+makedepends="python3-dev gfortran py3-numpy-dev freetype-dev
+ libpng-dev tk-dev py3-setuptools"
+checkdepends="py3-pytest xvfb"
source="$_pkgname-$pkgver.tar.gz::https://github.com/matplotlib/$_pkgname/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
# matplotlib provides unit tests, but they need to be run post installation :-(
options="!check"
+replaces="py-matplotlib" # Backwards compatibility
+provides="py-matplotlib=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-} python2-tkinter"
- _py python2
- # Remove documentation, doc-subpkg will use python3 version
- rm -rf "$subpkgdir/usr/share"
-}
-
-_py3() {
- depends="${depends//py-/py3-} python3-tkinter"
- _py python3
-}
-
-doc() {
- mkdir -p "${subpkgdir}/usr"
- mv "${pkgdir}/../py3-$_pkgname/usr/share" "$subpkgdir/usr/"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- cd "$builddir"
-
- $python setup.py install --prefix=/usr --root="$subpkgdir"
- install -m755 -d "$subpkgdir"/usr/share/licenses/$pkgname
- install -m644 LICENSE/* "$subpkgdir"/usr/share/licenses/$pkgname/
-}
-
sha512sums="d118f5d56e2f578031aba22933c0b3a4423a31a04f50f08cc1aa660186546d09692a9cf401bb5f24cb296f94fbfd8707460728d501ac2bd4a624dfa89e92949b matplotlib-2.2.3.tar.gz"