aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycups/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-09-20 13:28:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-20 17:20:39 +0000
commit15529a96a14295adf763eaadbd33a96c06931699 (patch)
tree3ad014ac1f617be38855bdf4e402ec3c6c295083 /testing/py3-pycups/APKBUILD
parente5fe31039b05a6d53a7d8d41ca2ebcb728ac0eec (diff)
testing/py3-pycups: new aport
Diffstat (limited to 'testing/py3-pycups/APKBUILD')
-rw-r--r--testing/py3-pycups/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pycups/APKBUILD b/testing/py3-pycups/APKBUILD
new file mode 100644
index 00000000000..fe5ef11ecc7
--- /dev/null
+++ b/testing/py3-pycups/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-pycups
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Python bindings for libcups"
+url="https://github.com/zdohnal/pycups"
+arch="all"
+license="GPL-2.0-or-later"
+depends="python3"
+makedepends="
+ cups-dev
+ py3-setuptools
+ python3-dev
+ "
+source="https://pypi.python.org/packages/source/p/pycups/pycups-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/pycups-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="fdebf1cac8cc4fffb8a76a938aa91965dae4a3dcdb6d8ee26e8e6054809d26dd3fb20b10c2351fb9265c03b16d6bde011815111c452ccb058518372f22d9d617 pycups-2.0.1.tar.gz"