aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pygdbmi/APKBUILD
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-10-08 15:40:44 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-11 02:14:02 -0300
commited6b5c875d0c5a70919899846650a2327aee0dda (patch)
tree0848614caf8e86fbcce4e0672583639dbd32b7a2 /testing/py3-pygdbmi/APKBUILD
parentbcad5108601a854bb0539b0088eb5b614a7b5ccf (diff)
testing/py3-pygdbmi: new aport
https://github.com/cs01/pygdbmi Get Structured Output from GDB's Machine Interface
Diffstat (limited to 'testing/py3-pygdbmi/APKBUILD')
-rw-r--r--testing/py3-pygdbmi/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pygdbmi/APKBUILD b/testing/py3-pygdbmi/APKBUILD
new file mode 100644
index 00000000000..e251438eac8
--- /dev/null
+++ b/testing/py3-pygdbmi/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+_pkgname=pygdbmi
+pkgname=py3-$_pkgname
+pkgver=0.9.0.2
+pkgrel=0
+pkgdesc="Get Structured Output from GDB's Machine Interface"
+url="https://github.com/cs01/pygdbmi"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py check
+}
+
+sha512sums="8341efd12b146f1d11a43c1fe20d065bc0dbc4e6f14c7f03917e06fcc77daca81d9497d236552b36fadadb310937bfdd91e073f171fe8b5bf2f8a95508c0a3fd pygdbmi-0.9.0.2.tar.gz"