aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pygpgme/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-07-10 12:55:14 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-08-30 10:25:02 +0000
commit0a098f37c9d2887a480d667f3b04f00c08937c80 (patch)
tree7c41b0bb083a4dc3c49996676b3c7e279aa26b50 /testing/py3-pygpgme/APKBUILD
parent43ad92d06f6230129167130182ff4b93aa34971c (diff)
testing/py3-pygpgme: new aport
Diffstat (limited to 'testing/py3-pygpgme/APKBUILD')
-rw-r--r--testing/py3-pygpgme/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pygpgme/APKBUILD b/testing/py3-pygpgme/APKBUILD
new file mode 100644
index 00000000000..5c34d834e74
--- /dev/null
+++ b/testing/py3-pygpgme/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: TBK <tbk@jjtc.eu>
+# Contributor: TBK <tbk@jjtc.eu>
+pkgname=py3-pygpgme
+_pkgname=pygpgme
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="PyGPGME is a Python module that lets you sign, verify, encrypt and decrypt messages using the OpenPGP format."
+url="https://launchpad.net/pygpgme"
+arch="all"
+license="LGPL2.1"
+depends="python3 gpgme"
+makedepends="python3-dev gpgme-dev"
+subpackages=""
+source="$_pkgname-${pkgver}.tar.gz::https://github.com/rshk/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f3c9de92956917f5e55c3a8d49be354d845e4f99b3a5173601841afcdd7b9ad270be0dea50468425c517328ceba46f1252685587bcf011287d1ed3a07b7ba8ab pygpgme-0.3.1.tar.gz"