aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pygpgme/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-02-23 10:17:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 02:16:02 -0300
commita46165c0c9227e9db67fd19eaf7cf8dd9c4fcccf (patch)
tree1076df6f4942a455de480acdc0f103515a4bb825 /testing/py3-pygpgme/APKBUILD
parenta21cea1afefa7954e01eb285f49f3d76f5dcbaa0 (diff)
testing/py3-pygpgme: modernize
Diffstat (limited to 'testing/py3-pygpgme/APKBUILD')
-rw-r--r--testing/py3-pygpgme/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/testing/py3-pygpgme/APKBUILD b/testing/py3-pygpgme/APKBUILD
index ecb3b7ab4f9..736777f8fce 100644
--- a/testing/py3-pygpgme/APKBUILD
+++ b/testing/py3-pygpgme/APKBUILD
@@ -3,24 +3,21 @@
pkgname=py3-pygpgme
_pkgname=pygpgme
pkgver=0.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="PyGPGME is a Python module that lets you sign, verify, encrypt and decrypt messages using the OpenPGP format."
-url="https://launchpad.net/pygpgme"
+url="https://github.com/rshk/pygpgme/"
arch="all"
-license="LGPL-2.1"
-depends="python3 gpgme"
-makedepends="python3-dev gpgme-dev"
-subpackages=""
-source="$_pkgname-${pkgver}.tar.gz::https://github.com/rshk/$_pkgname/archive/v$pkgver.tar.gz"
+license="LGPL-2.1-or-later"
+depends="python3"
+makedepends="gpgme-dev python3-dev"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/rshk/pygpgme/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}