aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyperclip
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-07-13 13:42:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 13:00:19 -0300
commitd8e80f5662a4f06bf7fc1238a2b59391d04ce3aa (patch)
tree564fcb2e4c2076ca0915f2d23c406946ba242ea5 /testing/py3-pyperclip
parentdb74d9ef6c529bba77a2d687711be42fb6b07233 (diff)
testing/py3-pyperclip: New aport
Python module for copy and paste clipboard functions https://github.com/asweigart/pyperclip
Diffstat (limited to 'testing/py3-pyperclip')
-rw-r--r--testing/py3-pyperclip/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pyperclip/APKBUILD b/testing/py3-pyperclip/APKBUILD
new file mode 100644
index 00000000000..d51e03d6e52
--- /dev/null
+++ b/testing/py3-pyperclip/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-pyperclip
+_pkgname=pyperclip
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Python module for copy and paste clipboard functions"
+url="https://github.com/asweigart/pyperclip"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+options="!check" # bug in tests prevents them from even starting :-/
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py test
+}
+sha512sums="7f22227ea894a236703f61ab950e198fab969fac5713ca8eac6df213183a47a244add88a462b9ddf63ed5bec36af5bc2578949f01ed31e0b63316d1761a935bd py3-pyperclip-1.7.0.tar.gz"