aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyphen
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-12 00:01:37 +0300
committerprspkt <prspkt@protonmail.com>2019-06-12 23:49:47 +0300
commit02c32c7b85e897132efb4622f7479a1031b73532 (patch)
tree866085cdb4c9695f744c3f3a4f7c29eb1fa45537 /testing/py3-pyphen
parent8d1c6b33391774a64430413805a34d6bcd616802 (diff)
testing/py3-pyphen: clarify license
* Switch url to https. * Pypi sources don't provide a test suite, switch to github. * Add py3-pytest checkdepends and run the test suite.
Diffstat (limited to 'testing/py3-pyphen')
-rw-r--r--testing/py3-pyphen/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/testing/py3-pyphen/APKBUILD b/testing/py3-pyphen/APKBUILD
index fa7f7702755..d6a76865cd3 100644
--- a/testing/py3-pyphen/APKBUILD
+++ b/testing/py3-pyphen/APKBUILD
@@ -5,12 +5,13 @@ _pkgname=Pyphen
pkgver=0.9.5
pkgrel=1
pkgdesc="python-based dictionary hyphenator library"
-url="http://www.pyphen.org/"
+url="https://www.pyphen.org"
arch="noarch"
-license="GPL-2.0-or-later MPL LGPL-2.0-or-later"
+license="GPL-2.0-or-later AND LGPL-2.1-or-later AND MPL-1.1"
depends="python3"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/Kozea/Pyphen/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-pyphen" # Backwards compatibility
@@ -21,11 +22,11 @@ build() {
}
check() {
- python3 setup.py test
+ py.test-3 -v test.py
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="15b9a29517df2b873b5b8d4739d8fa48a09ab199ab9246c7a4fd25c46253a74a18a88fd9484978476b3b1c8d88fed7729382b9dbe4f425724fe54bcd6227de96 Pyphen-0.9.5.tar.gz"
+sha512sums="049a62b226e90e568c8f56e756f8fa6fbc74f3bc40d61af8eb05ff2d4404a7b29cef14d4f144d68ed2f2b11eb128491de64536240ba7b76a2d04010c76e10346 Pyphen-0.9.5.tar.gz"