aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-addons/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:23:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:24:12 -0300
commite48d39f9de7e0349b3ebf270e50e94e971d53ced (patch)
tree61a1c237c2d1648bda4a7edb26248529d7a03383 /testing/py3-pyramid-addons/APKBUILD
parentb9521d323d37672ccf6daabee20b7209eef39467 (diff)
testing/py3-pyramid-addons: drop py2
Diffstat (limited to 'testing/py3-pyramid-addons/APKBUILD')
-rw-r--r--testing/py3-pyramid-addons/APKBUILD35
1 files changed, 11 insertions, 24 deletions
diff --git a/testing/py3-pyramid-addons/APKBUILD b/testing/py3-pyramid-addons/APKBUILD
index bff2c19d572..f791e43064c 100644
--- a/testing/py3-pyramid-addons/APKBUILD
+++ b/testing/py3-pyramid-addons/APKBUILD
@@ -1,41 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pyramid-addons
+pkgname=py3-pyramid-addons
_pkgname=pyramid_addons
pkgver=0.20
-pkgrel=0
+pkgrel=1
pkgdesc="A pyramid plugin that provides extra functionality"
+options="!check" # No testsuite
url="https://github.com/bboe/pyramid_addons"
arch="noarch"
-license="BSD"
-depends="python2 py-pyramid"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-2-Clause"
+depends="python3 py3-pyramid"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-pyramid-addons" # Backwards compatibility
+provides="py-pyramid-addons=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="b83599edf4af7d0cff1521aa44a73578 pyramid_addons-0.20.tar.gz"
-sha256sums="e0816e541296cb59ddf8426db442c7042b2798e661f2dae316075269b2bbbf5e pyramid_addons-0.20.tar.gz"
sha512sums="82916783fa13fb077fbc6bd76ee194dccff49dfaa1714d35ed6bad8062886851056326e6733d6e418528f957ab96e0b568caad16f9139386c0f5668e56fa41f4 pyramid_addons-0.20.tar.gz"