aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-shellingham
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 04:02:05 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commita5bfb5f401d5e6b94916ba9649cda51de60acba4 (patch)
tree4d80a63856e8ed6f213f6717f193a7d50ebcb975 /testing/py3-shellingham
parente601817daf931d1aa6c7b444fc4981bc59af0b74 (diff)
testing/py3-shellingham: new aport
Python3 module to poke around and find out running shell https://github.com/sarugaku/shellingham Closes GH-8381
Diffstat (limited to 'testing/py3-shellingham')
-rw-r--r--testing/py3-shellingham/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-shellingham/APKBUILD b/testing/py3-shellingham/APKBUILD
new file mode 100644
index 00000000000..5034f01c6ae
--- /dev/null
+++ b/testing/py3-shellingham/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-shellingham
+_realname=shellingham
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Python3 module to poke around and find out running shell"
+options="!check" # Requires unpackaged dependencies
+url="https://github.com/sarugaku/shellingham"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sarugaku/shellingham/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ba728bed5b3c0d715e8557f8364e98eebc006a4375b6e1a9c4be92571cd71c7bf6856571f3bf66879c8075fdfebc0a54a6a5190c40811b028616c5b28808d832 py3-shellingham-1.3.1.tar.gz"