aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-skia-pathops/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 17:39:54 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:09:47 +0100
commit3d7c83f869ec483e44c597d59765df6802dc27e5 (patch)
treec036c7c781e1b97a578ad73860a69c62c0939d8d /testing/py3-skia-pathops/APKBUILD
parent0e10f7c03a20d762aadd22bfea4b3bf1987927ab (diff)
testing/py3-skia-pathops: new aport
https://github.com/fonttools/skia-pathops Python bindings for the Skia library's Path Ops
Diffstat (limited to 'testing/py3-skia-pathops/APKBUILD')
-rw-r--r--testing/py3-skia-pathops/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-skia-pathops/APKBUILD b/testing/py3-skia-pathops/APKBUILD
new file mode 100644
index 00000000000..b5b352446d1
--- /dev/null
+++ b/testing/py3-skia-pathops/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-skia-pathops
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Python bindings for the Skia library's Path Ops"
+url="https://github.com/fonttools/skia-pathops"
+arch="all !s390x" # doesn't support big endian
+license="BSD-3-Clause"
+depends="python3 cython"
+makedepends="python3-dev py3-setuptools"
+options="!check" # missing deps: pytest-cython, pytest-randomly
+source="https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-$pkgver.zip"
+builddir="$srcdir/skia-pathops-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ed4deba9e6e3576cc4c550c0c0172b0780f1e8e1424f156e8ef893a62924fd91c16a3bf2e1598c3116a1a73958513339dce48a2978f86b27f285d6f0f50245eb skia-pathops-0.2.1.zip"