aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-tomlkit
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 03:51:10 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:34 +0000
commite601817daf931d1aa6c7b444fc4981bc59af0b74 (patch)
treebcd5c7d25866a9b1a3aa61f799fa6171b8f4662b /testing/py3-tomlkit
parentce9d87fe30f684ace09a623bf39d767539967649 (diff)
testing/py3-tomlkit: new aport
Python3 library for parsing and modifying TOML https://github.com/sdispater/tomlkit Closes GH-8381
Diffstat (limited to 'testing/py3-tomlkit')
-rw-r--r--testing/py3-tomlkit/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-tomlkit/APKBUILD b/testing/py3-tomlkit/APKBUILD
new file mode 100644
index 00000000000..df1c1d17704
--- /dev/null
+++ b/testing/py3-tomlkit/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-tomlkit
+_realname=tomlkit
+pkgver=0.5.3
+pkgrel=0
+pkgdesc="Python3 library for parsing and modifying TOML"
+options="!check" # No tests on pypi tarball, github uses pyproject.toml
+url="https://github.com/sdispater/tomlkit"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="90939b380fb8c58a1825c45740d599f116adf5075b1efb327ceb72353b1d1b3d6d6b960ed7673d46af586fc3ed56a866a6a8eb8dfc2a78ea128b5b7f214b0b55 tomlkit-0.5.3.tar.gz"