aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ujson
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-29 21:41:10 -0300
committerprspkt <prspkt@protonmail.com>2019-05-30 20:37:52 +0300
commit58f9f6376a4100ff6a196e0249911e48e9abd4ca (patch)
tree5ae242a15d99730be1dceb75e72e76b67d9d97a0 /testing/py3-ujson
parent28ad15c12f16ebdad2bdc668c4ed8f27a2c34f7a (diff)
testing/py3-ujson: modernize, fix license.
Diffstat (limited to 'testing/py3-ujson')
-rw-r--r--testing/py3-ujson/APKBUILD38
1 files changed, 8 insertions, 30 deletions
diff --git a/testing/py3-ujson/APKBUILD b/testing/py3-ujson/APKBUILD
index 2c248c5d522..6a7bc9ddb20 100644
--- a/testing/py3-ujson/APKBUILD
+++ b/testing/py3-ujson/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-ujson
+pkgname=py3-ujson
_pkgname=ujson
pkgver=1.35
-pkgrel=3
+pkgrel=4
pkgdesc="A fast Python JSON encoder and decoder"
-url="http://github.com/esnme/ultrajson"
+url="https://github.com/esnme/ultrajson"
arch="all"
-license="BSD"
-makedepends="python2-dev py-setuptools python3-dev"
+license="BSD-3-Clause"
+makedepends="py3-setuptools python3-dev"
checkdepends="py3-tz py3-six"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
source="$_pkgname-$pkgver.tar.gz::https://github.com/esnme/ultrajson/archive/v$pkgver.tar.gz
added-static-to-C-functions-where-possible.patch
lower-stack-usage.patch
@@ -18,37 +17,16 @@ source="$_pkgname-$pkgver.tar.gz::https://github.com/esnme/ultrajson/archive/v$p
builddir="$srcdir"/ultrajson-$pkgver
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
check() {
- cd "$builddir"
- ln -s ./build/lib.*/ujson.*.so ujson.so
- PYTHONPATH=. python3 tests/tests.py
+ ln -s ./build/lib.*/ujson.*.so ujson.so
+ PYTHONPATH=. python3 tests/tests.py
}
sha512sums="cd5dc8d08e072cf703aec7d689070713f7073c22f13167d7e10a89219179248d6668894c1d742ca658672bb82e1dccbf72e3fd69e036d8cb2ee0ee799d10db11 ujson-1.35.tar.gz