aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-w3lib/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-17 00:02:19 +0300
committerprspkt <prspkt@protonmail.com>2019-06-17 02:07:21 +0300
commitc24eb5b77f3f829e5a6e8c91fb5140b54090b353 (patch)
treeef87839a137d505a5a77990bd2f0e9af9a7a8ee7 /testing/py3-w3lib/APKBUILD
parent33ee483f9818d87678ae7b7370b86d683fb90308 (diff)
testing/py3-w3lib: clarify license, modernize
Diffstat (limited to 'testing/py3-w3lib/APKBUILD')
-rw-r--r--testing/py3-w3lib/APKBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/testing/py3-w3lib/APKBUILD b/testing/py3-w3lib/APKBUILD
index 7195698e1fa..f7f662b8557 100644
--- a/testing/py3-w3lib/APKBUILD
+++ b/testing/py3-w3lib/APKBUILD
@@ -7,26 +7,20 @@ pkgrel=0
pkgdesc="A library of web-related functions"
url="https://github.com/scrapy/w3lib"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="python3"
-depends_dev=""
makedepends="py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
replaces="py-w3lib" # Backwards compatibility
provides="py-w3lib=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}