aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-weasyprint
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-04-03 16:19:25 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-06-09 13:50:16 -0300
commit8ffbd5299a8bda1b1c2fad29ff867177c937ccf2 (patch)
tree6567562bb847dd46dd933aaeac52eac9a312d36d /testing/py3-weasyprint
parentee312f48b0731565f62598ba871c8f47ae55514a (diff)
py3-weasyprint: adopt; upgrade to v46
Diffstat (limited to 'testing/py3-weasyprint')
-rw-r--r--testing/py3-weasyprint/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py3-weasyprint/APKBUILD b/testing/py3-weasyprint/APKBUILD
new file mode 100644
index 00000000000..663c4ec62b5
--- /dev/null
+++ b/testing/py3-weasyprint/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-weasyprint
+_pyname=WeasyPrint
+pkgver=46
+pkgrel=0
+pkgdesc="cairo-based HTML renderer for python"
+url="http://weasyprint.org"
+arch="noarch"
+license="LGPL"
+depends="
+ pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2 py3-pyphen
+ py3-lxml py3-pdfrw
+"
+makedepends="python3-dev py-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pyname-$pkgver
+replaces="py-weasyprint py2-weasyprint"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ad7c231458ca3dc08d7816bd5710469fac094b08c5202b99f54da660ecea8367509bc938be752088a2e1639d9d87137b0afb82bdf74f272adb7d88c7b8790d8b WeasyPrint-46.tar.gz"