aboutsummaryrefslogtreecommitdiffstats
path: root/testing/python3/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2015-04-08 20:43:47 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2015-04-08 20:43:47 +0200
commit52cdd6464a706f939d813409fd3126edf0c9b1c9 (patch)
tree83960e1c8c4391443ec47778cb34dfee5f9ebc30 /testing/python3/APKBUILD
parent0515300d872788c9bf2d710b00e519aab4b28a96 (diff)
testing/python3: upgrade to 3.4.3
Diffstat (limited to 'testing/python3/APKBUILD')
-rw-r--r--testing/python3/APKBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/testing/python3/APKBUILD b/testing/python3/APKBUILD
index 164dcc5cb47..f1ee01b2533 100644
--- a/testing/python3/APKBUILD
+++ b/testing/python3/APKBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer:
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
pkgname=python3
-pkgver=3.4.2
-_pkgver=3.4
+pkgver=3.4.3
pkgrel=1
pkgdesc="A high-level scripting language"
url="http://www.python.org"
@@ -46,21 +48,22 @@ package() {
}
_mv_files() {
- cd "$pkgdir"/usr/lib/python$_pkgver
+ cd "$pkgdir"/usr/lib/python${pkgver%.*}
for i in */test */tests; do
- mkdir -p "$subpkgdir"/usr/lib/python$_pkgver/"$i"
- mv "$i"/* "$subpkgdir"/usr/lib/python$_pkgver/"$i"
+ mkdir -p "$subpkgdir"/usr/lib/python${pkgver%.*}/"$i"
+ mv "$i"/* "$subpkgdir"/usr/lib/python${pkgver%.*}/"$i"
rm -rf "$i"
done
- mv "$pkgdir"/usr/lib/python$_pkgver/test "$subpkgdir"/usr/lib/python$_pkgver
+ mv "$pkgdir"/usr/lib/python${pkgver%.*}/test \
+ "$subpkgdir"/usr/lib/python${pkgver%.*}
}
dev() {
# pyconfig.h is needed runtime so we move it back
default_dev
- mkdir -p "$pkgdir"/usr/include/python${_pkgver}m
- mv "$subpkgdir"/usr/include/python${_pkgver}m/pyconfig.h \
- "$pkgdir"/usr/include/python${_pkgver}m/
+ mkdir -p "$pkgdir"/usr/include/python${pkgver%.*}m
+ mv "$subpkgdir"/usr/include/python${pkgver%.*}m/pyconfig.h \
+ "$pkgdir"/usr/include/python${pkgver%.*}m/
}
tests() {
@@ -70,9 +73,9 @@ tests() {
_mv_files
}
-md5sums="36fc7327c02c6f12fa24fc9ba78039e3 Python-3.4.2.tar.xz
+md5sums="7d092d1bba6e17f0d9bd21b49e441dd5 Python-3.4.3.tar.xz
47be456068550c4239efbfa8866b5d6a posix_close.patch"
-sha256sums="1c6d9682d145c056537e477bbfa060ce727f9edd38df1827e0f970dcf04b2def Python-3.4.2.tar.xz
+sha256sums="b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8 Python-3.4.3.tar.xz
c34c2959e06e71d61116595d337dfa7f3c468ea775004a4fc53acc400972afe5 posix_close.patch"
-sha512sums="12de5309cfaf91f5292efd660b5abe31581b902fdcc302317b597ffa74c9f5ec14ec1dd55994bcccd50d40473ae344ae19bf917ccfb8ab4906c8777d6ea95b17 Python-3.4.2.tar.xz
+sha512sums="55b2d7c07da8ad3a3971b4687da2e45809c6f1474732e93b0432f121f287d0b63ad8a9bf381987ea70f47a03d9474c3e55b7d86d14800bf7ef29b3324d8d35b9 Python-3.4.3.tar.xz
a7f73fe2f114727999849cb8cecfd822025a129e57ae14ec0c1adc0ce6204c556467ea2d1008ce55745e692d2224f23774e1775316e3fdae812ac6c85e6780a2 posix_close.patch"