aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qqc2-desktop-style/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-24 09:27:00 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-24 07:56:06 -0300
commit79dace09a84124421b5a02589133f91386a47a5c (patch)
treee2434dbda249f745fe24f9ffe805b68a9da310a7 /testing/qqc2-desktop-style/APKBUILD
parentbb47d008e0d183d298b2625b4436bfa26646591c (diff)
testing/qqc2-desktop-style: new aport
Diffstat (limited to 'testing/qqc2-desktop-style/APKBUILD')
-rw-r--r--testing/qqc2-desktop-style/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/qqc2-desktop-style/APKBUILD b/testing/qqc2-desktop-style/APKBUILD
new file mode 100644
index 00000000000..c5df53d37f1
--- /dev/null
+++ b/testing/qqc2-desktop-style/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=qqc2-desktop-style
+pkgver=5.59.0
+pkgrel=0
+pkgdesc="A style for Qt Quick Controls 2 to make it follow your desktop theme"
+arch="all"
+url="https://community.kde.org/Frameworks"
+license="LGPL-3.0-only OR (GPL-2.0-only OR GPL-3.0-only)"
+depends="qt5-qtgraphicaleffects qt5-qtquickcontrols2"
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtx11extras-dev kirigami2-dev kiconthemes-dev kconfigwidgets-dev"
+makedepends="$depends_dev extra-cmake-modules"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="fc241c6be9edfa03108fc72f8b42d2ff0d19f90bb5cec52b1a35d9794c9a65f148b8d5ae0b1247904d1de76166f2cbaf4b0eb1dba5b8d2f51719ace526f0e964 qqc2-desktop-style-5.59.0.tar.xz"