aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rabbitmq-c/APKBUILD
diff options
context:
space:
mode:
authorNathan Johnson <njohnson@ena.com>2016-06-14 22:53:03 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-06-19 00:56:24 +0200
commit6af1dbb56d77f977fb0a3988940eaa628e068651 (patch)
treea9bc1f983f85cde42b90f51822ad9ec3533b8898 /testing/rabbitmq-c/APKBUILD
parentaf407b1002160f88150d020edd7914bec6ab81df (diff)
testing/rabbitmq-c: upgrade to 0.8.0 and split utils, dev, doc
Diffstat (limited to 'testing/rabbitmq-c/APKBUILD')
-rw-r--r--testing/rabbitmq-c/APKBUILD46
1 files changed, 35 insertions, 11 deletions
diff --git a/testing/rabbitmq-c/APKBUILD b/testing/rabbitmq-c/APKBUILD
index ef41bd5dc62..18612988605 100644
--- a/testing/rabbitmq-c/APKBUILD
+++ b/testing/rabbitmq-c/APKBUILD
@@ -1,27 +1,51 @@
# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
pkgname=rabbitmq-c
-pkgver=0.7.1
+pkgver=0.8.0
pkgrel=0
pkgdesc="RabbitMQ C client"
url="https://github.com/alanxz/rabbitmq-c"
arch="all"
license="MIT"
-source="https://github.com/alanxz/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$pkgname-$pkgver
+depends_dev="openssl-dev popt-dev"
+makedepends="$depends_dev cmake xmlto doxygen"
+subpackages="$pkgname-utils $pkgname-doc $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alanxz/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- ./configure --prefix=/usr || return 1
- make || return 1
+
+ mkdir -p build && cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ || return 1
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+utils() {
+ pkgdesc="$pkgdesc (command line utilities)"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+doc() {
+ pkgdesc="$pkgdesc (documentation and examples)"
+ arch="noarch"
+
+ mkdir -p "$subpkgdir"/usr/share/"$pkgname"
+ cp -a "$builddir"/build/docs "$builddir"/examples \
+ "$subpkgdir"/usr/share/"$pkgname"/
}
-md5sums="6216c8876299a5efc4ff5ff84dc636d8 rabbitmq-c-0.7.1.tar.gz"
-sha256sums="23df349a7d157543e756acc67e47b217843ecbdafaefe3e4974073bb99d8a26d rabbitmq-c-0.7.1.tar.gz"
-sha512sums="197b8476373e3a9056d5f24e0d932a37a556a946d2b6471c95e8b0e693b611de51882be4911bd099f2c2e76153225d83cac1bec8106c031058315f062a8a4ab4 rabbitmq-c-0.7.1.tar.gz"
+md5sums="51d5827651328236ecb7c60517c701c2 rabbitmq-c-0.8.0.tar.gz"
+sha256sums="d8ed9dcb49903d83d79d7b227da35ef68c60e5e0b08d0fc1fb4e4dc577b8802b rabbitmq-c-0.8.0.tar.gz"
+sha512sums="54e1c98a6b0eb7de848c9fac13dcde6455a6f71acee9e62a96c171f0e3e1cf860a70837f07b633d1a55b1ffd3d33ed7186b52495fa4c6e755b69a7e728eb9f1a rabbitmq-c-0.8.0.tar.gz"