aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rabbitmq-server
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 11:12:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 12:37:05 -0300
commit35c6452a338f6a7f1bfb9896cf43594b80eaf8c8 (patch)
tree06008061cd8a7a5e176b4d7068d6fdd05b451acf /testing/rabbitmq-server
parentc2fbad37637db450b37dccca09536cbcf7e1446a (diff)
testing/rabbitmq-server: rebuild with python3 makedepends
Diffstat (limited to 'testing/rabbitmq-server')
-rw-r--r--testing/rabbitmq-server/APKBUILD12
-rw-r--r--testing/rabbitmq-server/py3.patch112
2 files changed, 119 insertions, 5 deletions
diff --git a/testing/rabbitmq-server/APKBUILD b/testing/rabbitmq-server/APKBUILD
index 09f1259cc8b..79f5c28847d 100644
--- a/testing/rabbitmq-server/APKBUILD
+++ b/testing/rabbitmq-server/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
pkgname=rabbitmq-server
pkgver=3.7.17
-pkgrel=0
+pkgrel=1
pkgdesc="RabbitMQ is an open source multi-protocol messaging broker."
url="https://www.rabbitmq.com/"
arch="noarch !s390x"
@@ -11,7 +11,7 @@ depends="erlang erlang-tools erlang-runtime-tools erlang-stdlib
logrotate erlang-ssl erlang-crypto erlang-parsetools
erlang-mnesia erlang-sasl erlang-inets erlang-syntax-tools
erlang-eldap erlang-xmerl erlang-os-mon erlang-asn1 erlang-public-key"
-makedepends="$depends_dev erlang-dev python2 py2-simplejson xmlto libxslt
+makedepends="$depends_dev erlang-dev python3 py3-simplejson xmlto libxslt
rsync zip gawk grep erlang-compiler erlang-erl-docgen
erlang-edoc socat erlang-eunit elixir"
install="$pkgname.pre-install $pkgname.post-deinstall"
@@ -22,6 +22,7 @@ source="
rabbitmq-server.initd
rabbitmq-server.logrotate
https://github.com/rabbitmq/rabbitmq-server/releases/download/v$pkgver/rabbitmq-server-$pkgver.tar.xz
+ py3.patch
"
options="!check" # test suite broken
@@ -32,12 +33,12 @@ options="!check" # test suite broken
# - CVE-2019-11358
build() {
- make dist manpages
+ make dist manpages PYTHON=python3
}
package() {
make install install-bin install-man DESTDIR="$pkgdir" PREFIX=/usr \
- RMQ_ROOTDIR="/usr/lib/rabbitmq" MANDIR=/usr/share/man
+ RMQ_ROOTDIR="/usr/lib/rabbitmq" MANDIR=/usr/share/man PYTHON=python3
mkdir -p "$pkgdir"/var/lib/rabbitmq/mnesia
mkdir -p "$pkgdir"/var/log/rabbitmq
@@ -80,4 +81,5 @@ package() {
sha512sums="a8bb02a7cae1f8720e5c7aaabfe6a2c0e731cffbe0d8f99bdcb6597daa654dc49e6d41943974601435700cf469eaa8286dc91a3255a6b9023754c3861fbb5cd9 rabbitmq-server.initd
b8655cb048ab3b32001d4e6920bb5366696f3a5da75c053605e9b270e771c548e36858dca8338813d34376534515bba00af5e6dd7b4b1754a0e64a8fb756e3f3 rabbitmq-server.logrotate
-33af52a3f95854e7b3e067308181e37c7b9715b24e0ceb690d606f3e69a8be9cab258a18b68681350c31a01e4fa530825473bf652c7ac10894d36af4fa573a38 rabbitmq-server-3.7.17.tar.xz"
+33af52a3f95854e7b3e067308181e37c7b9715b24e0ceb690d606f3e69a8be9cab258a18b68681350c31a01e4fa530825473bf652c7ac10894d36af4fa573a38 rabbitmq-server-3.7.17.tar.xz
+7862c8566631aeb8c7756e5c8ea11705546ffcdca6ec9058516f91c2650a21b1bb373879e8eb8a78dc5af808eb1fdf6c8167997ea7feace2de61dfa1fb1e5c8b py3.patch"
diff --git a/testing/rabbitmq-server/py3.patch b/testing/rabbitmq-server/py3.patch
new file mode 100644
index 00000000000..24f3b067f57
--- /dev/null
+++ b/testing/rabbitmq-server/py3.patch
@@ -0,0 +1,112 @@
+diff --git a/deps/amqp10_common/codegen.py b/deps/amqp10_common/codegen.py
+index dc4480a..d573bcf 100755
+--- a/deps/amqp10_common/codegen.py
++++ b/deps/amqp10_common/codegen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ from __future__ import print_function
+
+diff --git a/deps/rabbit_common/codegen.py b/deps/rabbit_common/codegen.py
+index 8b81362..70bd7fa 100755
+--- a/deps/rabbit_common/codegen.py
++++ b/deps/rabbit_common/codegen.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ ## The contents of this file are subject to the Mozilla Public License
+ ## Version 1.1 (the "License"); you may not use this file except in
+diff --git a/deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/manage.py b/deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/manage.py
+index 1ae2e80..3e61442 100755
+--- a/deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/manage.py
++++ b/deps/rabbitmq_auth_backend_http/examples/rabbitmq_auth_backend_django/manage.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ import os
+ import sys
+
+diff --git a/deps/rabbitmq_consistent_hash_exchange/README.md b/deps/rabbitmq_consistent_hash_exchange/README.md
+index ce1623f..6ff906b 100644
+--- a/deps/rabbitmq_consistent_hash_exchange/README.md
++++ b/deps/rabbitmq_consistent_hash_exchange/README.md
+@@ -150,7 +150,7 @@ Executable versions of some of the code examples can be found under [./examples]
+ This version of the example uses [Pika](https://pika.readthedocs.io/en/stable/), the most widely used Python client for RabbitMQ:
+
+ ``` python
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+@@ -342,7 +342,7 @@ routed to the same **arbitrarily chosen** queue.
+ #### Code Example in Python
+
+ ``` python
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+@@ -544,7 +544,7 @@ routed to the same **arbitrarily chosen** queue.
+ #### Code Example in Python
+
+ ``` python
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+diff --git a/deps/rabbitmq_consistent_hash_exchange/examples/python/example1.py b/deps/rabbitmq_consistent_hash_exchange/examples/python/example1.py
+index 6cf67d6..30e43ea 100644
+--- a/deps/rabbitmq_consistent_hash_exchange/examples/python/example1.py
++++ b/deps/rabbitmq_consistent_hash_exchange/examples/python/example1.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+diff --git a/deps/rabbitmq_consistent_hash_exchange/examples/python/example2.py b/deps/rabbitmq_consistent_hash_exchange/examples/python/example2.py
+index 8c1ac15..0099b28 100644
+--- a/deps/rabbitmq_consistent_hash_exchange/examples/python/example2.py
++++ b/deps/rabbitmq_consistent_hash_exchange/examples/python/example2.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+diff --git a/deps/rabbitmq_consistent_hash_exchange/examples/python/example3.py b/deps/rabbitmq_consistent_hash_exchange/examples/python/example3.py
+index 0b74501..c11a4ce 100644
+--- a/deps/rabbitmq_consistent_hash_exchange/examples/python/example3.py
++++ b/deps/rabbitmq_consistent_hash_exchange/examples/python/example3.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import pika
+ import time
+diff --git a/deps/rabbitmq_management/bin/rabbitmqadmin b/deps/rabbitmq_management/bin/rabbitmqadmin
+index 55173cb..04c0c12 100755
+--- a/deps/rabbitmq_management/bin/rabbitmqadmin
++++ b/deps/rabbitmq_management/bin/rabbitmqadmin
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ # The contents of this file are subject to the Mozilla Public License
+ # Version 1.1 (the "License"); you may not use this file except in
+diff --git a/deps/rabbitmq_trust_store/examples/rabbitmq_trust_store_django/manage.py b/deps/rabbitmq_trust_store/examples/rabbitmq_trust_store_django/manage.py
+index 469f277..ea21f63 100755
+--- a/deps/rabbitmq_trust_store/examples/rabbitmq_trust_store_django/manage.py
++++ b/deps/rabbitmq_trust_store/examples/rabbitmq_trust_store_django/manage.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ import os
+ import sys
+
+