aboutsummaryrefslogtreecommitdiffstats
path: root/testing/raft/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2020-10-03 11:40:21 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2020-10-04 15:40:18 +0000
commitbb4aa1a423148e028583739cb3dcfcae361bdd8e (patch)
tree464ecd6bffaa814a5c1795587bd2e860620219a4 /testing/raft/APKBUILD
parent9a974ec3a0b1621cf0f47a255acd8a3bbaa5fcc1 (diff)
testing/raft: new aport
Diffstat (limited to 'testing/raft/APKBUILD')
-rw-r--r--testing/raft/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/raft/APKBUILD b/testing/raft/APKBUILD
new file mode 100644
index 00000000000..e6d0b795bfc
--- /dev/null
+++ b/testing/raft/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=raft
+pkgver=0.9.25
+pkgrel=0
+pkgdesc="C implementation of the Raft consensus protocol"
+url="https://github.com/canonical/raft"
+arch="all"
+license="LGPL3"
+makedepends="linux-headers libuv-dev autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/canonical/raft/archive/v$pkgver.tar.gz
+ unistd-include.patch"
+
+prepare() {
+ default_prepare
+ autoreconf -i
+}
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --enable-static=no \
+ --enable-example=no
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha512sums="8709a909c527b7062072165356dcc012cf7af6cf85e3a3be515220ea4a863637dd06e7c4376af4284006bce65034002d1639ca52ac1ce108be2efa0725a82b70 raft-0.9.25.tar.gz
+d0f204a271ac40bf9b36027f2a0ee53195aad7366c0166a7f6268bac5bfb05546a5ef858f466c4bbc2a0c6a50dff8d9bc3314abd125f25d49ed5aab9641527b2 unistd-include.patch"