aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust/APKBUILD
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-20 02:32:14 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-21 01:44:33 +0200
commit06ef4afb639890920801ec034cffaa31ab25b98c (patch)
tree063d460d510221d1814f18aeec1c6010f4248a03 /testing/rust/APKBUILD
parent3b034a254fa89558cf04d8e54ee6d01f28bdf85b (diff)
testing/rust: properly force RPATH with a new target option
These patches add a new target option, `need_rpath`, to force RPATH embedding in appropriate situations. We also minimize the generated RPATH.
Diffstat (limited to 'testing/rust/APKBUILD')
-rw-r--r--testing/rust/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index a8e6c4f2cf6..c90428ed080 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -35,10 +35,12 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
static-pie.patch
llvm-with-ffi.patch
alpine-musl-dynamic-linking-by-default.patch
+ need-rpath.patch
+ minimize-rpath.patch
alpine-allow-crt-static.patch
alpine-move-py-scripts-to-share.patch
alpine-change-rpath-to-rustlib.patch
- alpine-force-rpath-on-prefer-dynamic.patch
+ alpine-need-rpath.patch
check-rustc
"
builddir="$srcdir/rustc-$pkgver-src"
@@ -191,8 +193,10 @@ c913d04ef419b2b6d8e453f72894070f263c9292abf97114a51884d475d03ce5b032053f1676ba93
5881cb63c77a566aab80428084297fa278c04aeb5fe4e7a3a32655f2b97cdb5b0712fe859662392393dbbb4b2723be543a0207f6b75961a5fb79351c02c107a9 static-pie.patch
dc6432293bd060d5e3a73f25870867654fae61995dcd919e244a2dc686b6107556deed8c59ca6002182bfeff5ebc1ca2b89c4028ab0fbfb79e65defe47c9b4b0 llvm-with-ffi.patch
44f3104f506531778fede64034ff5b86f782744d7fed26b393cd88590c22b7fd1df441e2c14bb44c660c54140a4093686aa35f53357f9cd795af6cfa6df1cec4 alpine-musl-dynamic-linking-by-default.patch
+ff633f2a46c683ad698d1c09c98c06ce9ee9b8d55fa5593cdd485b439ebca3273794d29b5ff32b887be8666f52913a23af6e133c782bd0c4e2c88e306dd3a494 need-rpath.patch
+d352614e7c774e181decae210140e789de7fc090327ff371981ad28a11ce51c8c01b27c1101a24bb84d75ed2f706f67868f7dbc52196d4ccdf4ebd2d6d6b6b5e minimize-rpath.patch
b00997c65d1a451fafae8b547893c5cbf03f028d2d70f6971aa670f34c2d6fc82728c740ac4a9909fc1999925ff300e4525cfec745cb9c9521e564eb166872a2 alpine-allow-crt-static.patch
498f4649163974afc4f042c43cd0c15d36784031514201a2962061f288a9336c2bc9749f8d2308b8ce3656f8097b5fc5bef505f61e2a6ed422ef4153f5339d77 alpine-move-py-scripts-to-share.patch
8d6206f8c50856724cf7b4c1854ec82547f040358a1c7d44abeacc27a5c205a963b1fec51e58ec06c68d85bd2f68a9e6e27ebe457f39e8dd043de17758f5063f alpine-change-rpath-to-rustlib.patch
-f230239d8de1b69536353e5735d3bf32f42a2715aefe4863622d9ab2b25d010209ed0bb38976eaa9302bce2eca6bd162abc8cefd71f689b65b3800920a50967b alpine-force-rpath-on-prefer-dynamic.patch
+816068be3ef92b3a67dedc3c4cf80b647f4a40743dc06a50801ba3a1bd3194f244bd7498f57db781f625a0c0da9605ef42e6dae6b781ad6c7f73ec5b45242e98 alpine-need-rpath.patch
79549055dea81379c890b495c82456ab497a9179ec6702c59e11d0748bc668f47fc3d6a69c27a0545bb87c01318631dffc69260bf2d4badc75f53cbf7fad7528 check-rustc"