aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-08 23:53:16 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-09 15:41:28 +0200
commit60dcefecf12e7926c72ac932e8aaf1d1945341e5 (patch)
tree053144b2094fbaa999eccddc7b8bb25f5e445f01 /testing/rust/APKBUILD
parent2da58e99823d6c81ca41dbc3d8334a47a10af5ea (diff)
testing/rust: add check for static/dynamic PIC
Diffstat (limited to 'testing/rust/APKBUILD')
-rw-r--r--testing/rust/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 8f5ffd5e875..7655f2174a9 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -37,8 +37,8 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz
move-py-scripts-to-share.patch
change-rpath-to-rustlib.patch
fix-jemalloc-musl.patch
+ check-rustc
"
-options="!check"
builddir="$srcdir/rustc-$pkgver-src"
_ctarget="$CARCH-unknown-linux-musl"
@@ -100,12 +100,14 @@ build() {
}
check() {
- cd "$builddir"
-
- make check \
- LD_LIBRARY_PATH="$_stage0dir/lib" \
- RUST_BACKTRACE=1 \
- VERBOSE=1
+ "$srcdir"/check-rustc "$builddir/build/$_ctarget/stage2/bin/rustc"
+
+# XXX: There's some problem with these tests, we will figure it out later.
+# cd "$builddir"
+# make check \
+# LD_LIBRARY_PATH="$_stage0dir/lib" \
+# RUST_BACKTRACE=1 \
+# VERBOSE=1
}
package() {
@@ -178,10 +180,11 @@ e9b10d58ae5b51b09dd31a1dbf7367917bd40a05ecb4ba3e0e7ac229a0352d3ceb77de80f7c0120f
4df33353b6be1af822220ca03f9ec5a3b6421c9b10ec17b864be586ba495c6210bac70d904b0e0b35eff62ef2c9a681ded526e5cbd37e326dc3146742aa659de cargo-6e0c18cccc8b0c06fba8a8d76486f81a792fb420-x86_64-unknown-linux-musl.tar.gz
2002faf08cca3be702f25618bc17453c5e76644a6ff6b0739b642c2c0f8536ec7f09c98182aff6b2dcc87c77b0929f2f8f732b8242a8f80d94b3824c8cd0d0fe dont-require-filecheck.patch
a87ffe129debcb9fa958c6d007ffa4a87927890030e0694ee5ab1929ea0c5a48dad86b4e8b71550dcfeda29b644dbb23d8b232bda62439f198a404cf658c68b0 support-dynamically-linked-musl.patch
-57ea7651bc0b0fa5340b9c5de0492ddc8bfaf4f1003298bf27dea57ee562cdd0f3947e091b154388535ce511e001e052f12d48805f7ffece7f04178ad409623f allow-crt-static-on-stable.patch
+7e2a282332d22d22a0d48da34cc9e83db7acbf38787bc3b18c49dd2cdc112ca76ebfa40e5b9629a80ae73632b4b0fea278b9ff4cdc56ddb7dd265958b509afab allow-crt-static-on-stable.patch
541aac679dfdbe5383f884e0493462dd33908308c7b294170b24339d6b9c1e723088c80764125116f24707a67eeeedadceaa9628ca6d2b8c7d0ca9253bf62135 static-pie.patch
f436fddf7ab70ca5f1424081f5b75450270b200b3d997231323863e11addf76e1d65831a7ca09e3a5b7904ce828766c1f70b08326a175890298f28e5bc8646ef fix-linux_musl_base.patch
37416e1fa0bc0c8651cd060a645d6245ff7e2082279ab5e13495c5ee412c71915469019cfbec95a0fd9a7fc144475079a3ad16f0eba7a2f5c8dd99e0002f3225 llvm-with-ffi.patch
19cc2725d68db3e359e0e3016028374e5818a97fdba24d0103f7d1706601c8b17c4dd95a3152e64f982f98e95ad3e949acddbea8a39ed0ba8dd4f702acc2704d move-py-scripts-to-share.patch
8d6206f8c50856724cf7b4c1854ec82547f040358a1c7d44abeacc27a5c205a963b1fec51e58ec06c68d85bd2f68a9e6e27ebe457f39e8dd043de17758f5063f change-rpath-to-rustlib.patch
-a330fa913faeadb98cb95e644f434ddef4fbbea32bcd11b6621fb9e08f7b0d8c71fae702207465489af3cf793eade0af694a8c515fc1bed49624da25103a4862 fix-jemalloc-musl.patch"
+a330fa913faeadb98cb95e644f434ddef4fbbea32bcd11b6621fb9e08f7b0d8c71fae702207465489af3cf793eade0af694a8c515fc1bed49624da25103a4862 fix-jemalloc-musl.patch
+770cf8d2d3d55647ba551ae98314af6b6c09e5994cfae0c2ef7ee05ccbf8efa05308887d61a017ab53dee18723db3a5177ce145e43af20326cf156dd2bd0e360 check-rustc"