aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rust/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-08 22:22:46 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-09 15:41:28 +0200
commit856faeea63600f75d928ead679d34800c0b7531e (patch)
treed5de44053631b4612899922a9688848fd6bcbf20 /testing/rust/APKBUILD
parent2f952ff8bc6c92a3546e39f25b0267cc57dc8487 (diff)
testing/rust: remove unneeded crt*.o files
Diffstat (limited to 'testing/rust/APKBUILD')
-rw-r--r--testing/rust/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/rust/APKBUILD b/testing/rust/APKBUILD
index 73b358534ff..2295562388b 100644
--- a/testing/rust/APKBUILD
+++ b/testing/rust/APKBUILD
@@ -13,7 +13,7 @@ license="ASL-2.0 BSD ISC MIT"
# gcc is needed at runtime just for linking. Someday rustc might invoke
# the linker directly, and then we'll only need binutils.
# See: https://github.com/rust-lang/rust/issues/11937
-depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc"
+depends="$pkgname-stdlib=$pkgver-r$pkgrel gcc musl-dev"
# libffi-dev is needed just because we compile llvm with LLVM_ENABLE_FFI.
makedepends="cmake file libffi-dev libunwind-dev llvm llvm-dev
musl-dev python2 tar zlib-dev"
@@ -117,6 +117,9 @@ package() {
# them. Read change-rpath-to-rustlib.patch for more info.
rm -r usr/lib/*.so
+ # These objects are for static linking with musl on non-musl systems.
+ rm $_rlibdir/crt*.o
+
# Shared objects should have executable flag.
chmod +x $_rlibdir/*.so