aboutsummaryrefslogtreecommitdiffstats
path: root/testing/secpwgen/make-openssl.patch
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-07-21 23:43:30 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-07-22 06:03:00 +0000
commit01df39f0e258c60abf64d75e2bd6586a5c139ce2 (patch)
treec076b8415f00ec5d198e7ef71696a9c27091db3c /testing/secpwgen/make-openssl.patch
parent28547bccfb769f683772e3ef776a5ae16181c4c3 (diff)
testing/secpwgen: new aport
A utility for generating secure passphrases. Implements several methods for passphrase generation, including the Diceware method with 8192 word dictionary compiled in the executable. http://linux.die.net/man/1/secpwgen As it builds against OpenSSL you need to run haveged if you use this. Used in OpenSUSE & Midnight BSD.
Diffstat (limited to 'testing/secpwgen/make-openssl.patch')
-rw-r--r--testing/secpwgen/make-openssl.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/secpwgen/make-openssl.patch b/testing/secpwgen/make-openssl.patch
new file mode 100644
index 00000000000..f1de454ce85
--- /dev/null
+++ b/testing/secpwgen/make-openssl.patch
@@ -0,0 +1,33 @@
+--- secpwgen-1.3/Makefile.proto 2015-07-21 20:15:10.000000000 +0000
++++ secpwgen-1.3/Makefile.proto.new 2015-07-21 22:03:47.511905311 +0000
+@@ -30,9 +30,9 @@
+ ##
+ # If using OpenSSL, uncomment the following 3 lines.
+ ##
+-#CRYPTO_CFLAGS =
+-#CRYPTO_OBJS = secure_random_openssl.o
+-#CRYPTO_LIBS = -lcrypto
++CRYPTO_CFLAGS =
++CRYPTO_OBJS = secure_random_openssl.o
++CRYPTO_LIBS = -lcrypto
+
+ ##
+ # If using cryptlib, uncomment the following 3 lines.
+@@ -45,7 +45,7 @@
+ # Change PREFIX to install to different directories. The binary is installed
+ # in $PREFIX/bin, and the man in $PREFIX/man/man1
+ ##
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ ##
+ # On some operating systems (most notably Linux 2.6 kernels) using mlockall
+@@ -60,7 +60,7 @@ PREFIX = /usr/local
+ # Sometimes you have only dynamic libraries available. In that case COMMENT
+ # the following line.
+ ##
+-LINK_STATIC = -static
++#LINK_STATIC = -static
+
+ ##############################################################################
+ # NO USER MODIFIABLE PARTS AFTER THIS POINT