summaryrefslogtreecommitdiffstats
path: root/testing/shadow
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-21 11:37:26 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-21 11:37:26 -0500
commit315cd8fadda7e840da2fca369985e99637051413 (patch)
tree03b65fb4939e420c02db2b6007d27c1c2a1acfd8 /testing/shadow
parentb1abb04596bc35950af8f18b9799afe3a75a4377 (diff)
testing/shadow: new aport
Diffstat (limited to 'testing/shadow')
-rw-r--r--testing/shadow/APKBUILD45
-rw-r--r--testing/shadow/shadow.post-deinstall4
-rw-r--r--testing/shadow/shadow.post-upgrade4
3 files changed, 53 insertions, 0 deletions
diff --git a/testing/shadow/APKBUILD b/testing/shadow/APKBUILD
new file mode 100644
index 00000000000..7800e603443
--- /dev/null
+++ b/testing/shadow/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=shadow
+pkgver=4.1.4.3
+pkgrel=0
+pkgdesc="PAM-using login and passwd utilities"
+url="http://pkg-shadow.alioth.debian.org/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="linux-pam-dev"
+makedepends="$depends_dev"
+install="$pkgname.post-upgrade $pkgname.post-deinstall"
+subpackages="$pkgname-doc"
+source="http://pkg-shadow.alioth.debian.org/releases/shadow-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/shadow-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --without-nscd \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b8608d8294ac88974f27b20f991c0e79 shadow-4.1.4.3.tar.bz2"
diff --git a/testing/shadow/shadow.post-deinstall b/testing/shadow/shadow.post-deinstall
new file mode 100644
index 00000000000..dd117e5d80f
--- /dev/null
+++ b/testing/shadow/shadow.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+
diff --git a/testing/shadow/shadow.post-upgrade b/testing/shadow/shadow.post-upgrade
new file mode 100644
index 00000000000..dd117e5d80f
--- /dev/null
+++ b/testing/shadow/shadow.post-upgrade
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+busybox --install -s
+