aboutsummaryrefslogtreecommitdiffstats
path: root/testing/snapper/musl-mktime.patch
diff options
context:
space:
mode:
authorStefan R <kroko87@hotmail.com>2019-02-11 13:07:56 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-05 15:56:54 +0000
commit7f90328d3f882f558e1a22830974308c31fef713 (patch)
treeb04dea3c2ee2d2f68a5f33a39346c4b6faf60101 /testing/snapper/musl-mktime.patch
parentea7dc18423e0a5abcb98e7fedf1188a0b86a4905 (diff)
testing/snapper: config and musl fixes
Add dbus as dependency. Readd dbus config files in remove-systemd.patch. Fix conjob paths in scripts/Makefile.am. Install data/sysconfig.snapper to /etc/conf.d/snapper. Disable ext4 support, because it is experimental and not support with standard kernel and tools. Fix regex (because the '?' operator isn't supported). Fix strptime in snapper/AppUtil.cc, because musl doesn't support '%F'.
Diffstat (limited to 'testing/snapper/musl-mktime.patch')
-rw-r--r--testing/snapper/musl-mktime.patch12
1 files changed, 8 insertions, 4 deletions
diff --git a/testing/snapper/musl-mktime.patch b/testing/snapper/musl-mktime.patch
index 48fbc0802e5..22cbff4888b 100644
--- a/testing/snapper/musl-mktime.patch
+++ b/testing/snapper/musl-mktime.patch
@@ -2,10 +2,14 @@ According to http://ftp.gnu.org/old-gnu/Manuals/glibc-2.2.3/html_chapter/libc_21
timelocal(2) is functionally identical to mktime(2), but more
mnemonically named. There is no timelocal(2) defined in musl libc.
---- a/snapper/AppUtil.cc 2015-02-18 18:54:03.000000000 +0100
-+++ b/snapper/AppUtil.cc 2015-08-30 10:39:31.318158599 +0200
-@@ -274,7 +274,7 @@
- const char* p = strptime(str.c_str(), "%F %T", &s);
+--- a/snapper/AppUtil.cc
++++ b/snapper/AppUtil.cc
+@@ -279,10 +279,10 @@
+ {
+ struct tm s;
+ memset(&s, 0, sizeof(s));
+- const char* p = strptime(str.c_str(), "%F %T", &s);
++ const char* p = strptime(str.c_str(), "%Y-%m-%d %T", &s);
if (!p || *p != '\0')
return (time_t)(-1);
- return utc ? timegm(&s) : timelocal(&s);