aboutsummaryrefslogtreecommitdiffstats
path: root/testing/snes9x
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-08-26 14:15:30 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 10:37:18 +0000
commita43a193093249ac00e12dad4960a130e4dfa88a9 (patch)
tree3365426d498800eae0379cf2fe9607564ddf2122 /testing/snes9x
parentc045c835e171568e0c695a1f623270c584214545 (diff)
testing/snes9x: Upgrade to 1.56.2
* Switch to Gtk-2
Diffstat (limited to 'testing/snes9x')
-rw-r--r--testing/snes9x/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/snes9x/APKBUILD b/testing/snes9x/APKBUILD
index 7457571d866..e2387a3b1b0 100644
--- a/testing/snes9x/APKBUILD
+++ b/testing/snes9x/APKBUILD
@@ -1,14 +1,17 @@
# Contributor: Taner Tas <taner76@gmail.com>
# Maintainer: Taner Tas <taner76@gmail.com>
pkgname=snes9x
-pkgver=1.55
+pkgver=1.56.2
pkgrel=0
pkgdesc="Super NES Emulator"
url="http://www.snes9x.com"
arch="all"
license="custom"
-makedepends="nasm autoconf automake libpng-dev zlib-dev libxml2-dev
- alsa-lib-dev minizip-dev portaudio-dev gtk+3.0-dev sdl-dev"
+makedepends="
+ nasm autoconf automake libpng-dev zlib-dev libxml2-dev
+ alsa-lib-dev minizip-dev portaudio-dev gtk+2.0-dev sdl-dev
+ libxrandr-dev libepoxy-dev
+ "
subpackages="$pkgname-lang $pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}git/${pkgname}/archive/${pkgver}.tar.gz"
@@ -21,6 +24,7 @@ prepare() {
check() {
cd "$builddir"/gtk
+ echo "src/gtk_shader_parameters.cpp" >> po/POTFILES.in
make check
}
@@ -37,7 +41,7 @@ build() {
--prefix=/usr \
--with-netplay \
--with-opengl \
- --with-gtk3 \
+ --with-gtk2 \
--without-pulseaudio
make
}
@@ -49,4 +53,4 @@ package() {
install -D -m644 "$builddir"/docs/snes9x-license.txt "$pkgdir"/usr/share/doc/${pkgname}/snes9x-license.txt
}
-sha512sums="61d1d6f9c1fc4fbf6253ac7a7d214c771563d7d60238197b2f1525a58f8f9011446f400767d39ec464c69d80574a7dcd78557c8f47605df992af28cb107c0f6e snes9x-1.55.tar.gz"
+sha512sums="d9c53eb2a1200af26fdb39578f0b8b7cf42473110c2eb53799acd69f15055732d0487982e7cebacc4aa18a9e88bd9939a0b11f3ddf685af02becace1fd85105c snes9x-1.56.2.tar.gz"