aboutsummaryrefslogtreecommitdiffstats
path: root/testing/speexdsp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-18 14:18:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-18 14:36:33 +0000
commitd3161d5afbea4eb503522ee505965d95b626d566 (patch)
tree5b41c7342247a8135dc435fee04d7a7ff8f8d06a /testing/speexdsp
parent03b2fcf78790bb2ce0e8d1d367f0b7d4e67a5dfd (diff)
testing/speexdsp: new aport
A voice compression format (DSP) http://www.speex.org/
Diffstat (limited to 'testing/speexdsp')
-rw-r--r--testing/speexdsp/APKBUILD54
-rw-r--r--testing/speexdsp/speexdsp-fixbuilds-774c87d.patch36
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/speexdsp/APKBUILD b/testing/speexdsp/APKBUILD
new file mode 100644
index 00000000000..f0fc4048fd6
--- /dev/null
+++ b/testing/speexdsp/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Natanel Copa <ncopa@alpinelinux.org>
+pkgname=speexdsp
+pkgver=1.2_rc3
+_ver=${pkgver%_*}${pkgver#*_}
+pkgrel=2
+pkgdesc="A voice compression format (DSP)"
+url="http://www.speex.org/"
+arch="all"
+license="BSD"
+depends=
+makedepends="autoconf automake libtool"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.xiph.org/releases/speex/speexdsp-$_ver.tar.gz
+ speexdsp-fixbuilds-774c87d.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$_ver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ autoreconf -vif
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="70d9d31184f7eb761192fd1ef0b73333 speexdsp-1.2rc3.tar.gz
+c4fc8b6d6ca81a9e48062d2cc1259693 speexdsp-fixbuilds-774c87d.patch"
+sha256sums="4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1 speexdsp-1.2rc3.tar.gz
+76cd6b1187f415d966c8d62003cd87cfb66e4030b250a316aab8f0fbc2de226a speexdsp-fixbuilds-774c87d.patch"
+sha512sums="29dfa8345df025eeb076561648a9b5c0485692be699b6da3c2a3734b4329187a1c2eb181252f4df12b21f1309ecdf59797437dfb123d160fd723491ab216e858 speexdsp-1.2rc3.tar.gz
+0f0c8054591915a4ea06b28b13d50da41be10d594f39a0496e2e80e4514ed53db7cd0e1fdb205ce5e87f602b9c1e15409c33cf946ab25cdef8a3b147dbfcc0f3 speexdsp-fixbuilds-774c87d.patch"
diff --git a/testing/speexdsp/speexdsp-fixbuilds-774c87d.patch b/testing/speexdsp/speexdsp-fixbuilds-774c87d.patch
new file mode 100644
index 00000000000..c02ee29bd7d
--- /dev/null
+++ b/testing/speexdsp/speexdsp-fixbuilds-774c87d.patch
@@ -0,0 +1,36 @@
+diff --git a/configure.ac b/configure.ac
+index 2cd2d1e..1de0c23 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
+ AC_SUBST([SIZE32])
+ AC_SUBST([USIZE32])
+
++AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
++ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
++ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
++
++AC_SUBST([INCLUDE_STDINT])
++
+ AC_CONFIG_FILES([
+ Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
+ include/Makefile include/speex/Makefile speexdsp.pc
+diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
+index 02b82fd..5ea7b55 100644
+--- a/include/speex/speexdsp_config_types.h.in
++++ b/include/speex/speexdsp_config_types.h.in
+@@ -1,13 +1,7 @@
+ #ifndef __SPEEX_TYPES_H__
+ #define __SPEEX_TYPES_H__
+
+-#if defined HAVE_STDINT_H
+-# include <stdint.h>
+-#elif defined HAVE_INTTYPES_H
+-# include <inttypes.h>
+-#elif defined HAVE_SYS_TYPES_H
+-# include <sys/types.h>
+-#endif
++@INCLUDE_STDINT@
+
+ typedef @SIZE16@ spx_int16_t;
+ typedef @USIZE16@ spx_uint16_t;