aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spring-boot-openrc/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-07-14 02:36:04 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-07-14 02:45:00 +0200
commit3747a682608f79ca2ec58014d3ff1e921eaf0f3d (patch)
tree17a96e547c59a1b0f07c11fbdbfef57bc271f52f /testing/spring-boot-openrc/APKBUILD
parentfe74d94d5f16e4cec728d7a315ccf40b06e18b92 (diff)
testing/spring-boot-openrc: new aport
https://github.com/jirutka/spring-boot-openrc OpenRC runscript for Java applications based on Spring Boot
Diffstat (limited to 'testing/spring-boot-openrc/APKBUILD')
-rw-r--r--testing/spring-boot-openrc/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/spring-boot-openrc/APKBUILD b/testing/spring-boot-openrc/APKBUILD
new file mode 100644
index 00000000000..52fbfe001a6
--- /dev/null
+++ b/testing/spring-boot-openrc/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=spring-boot-openrc
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="OpenRC runscript for Java applications based on Spring Boot"
+url="https://github.com/jirutka/spring-boot-openrc"
+arch="noarch"
+license="MIT"
+depends="socat"
+makedepends=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ./install
+}
+
+md5sums="1f54bd769881d4205da9d07738d72b25 spring-boot-openrc-0.1.0.tar.gz"
+sha256sums="615598ae92984dadbaae92b1d91dcaa55dfd4a6b2785dbb9e832e5784d4bc3c4 spring-boot-openrc-0.1.0.tar.gz"
+sha512sums="9c0751b6e95974dd51d30a5ce6ce2d463cdd2efbc4eba5042e23905cf52a913b56cce878ed3c426417a316f0bcd3a38c0a1b56acd024783880c1fc0655838440 spring-boot-openrc-0.1.0.tar.gz"