aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sssd/0003-alpine.patch
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-10-23 21:49:08 +0200
committerHenrik Riomar <henrik.riomar@gmail.com>2018-10-23 21:53:42 +0200
commitfd86f562aef1fe82586768e1216628ad3fe51255 (patch)
tree60eea17d759bbbe05f05980a0b36d497a11b2a98 /testing/sssd/0003-alpine.patch
parent03081d44a1bbc60202b254fe8422f5ed043f5f0b (diff)
testing/sssd: upgrade to 1.16.3
* Improved the configure flags * Rebased the patches with git
Diffstat (limited to 'testing/sssd/0003-alpine.patch')
-rw-r--r--testing/sssd/0003-alpine.patch104
1 files changed, 47 insertions, 57 deletions
diff --git a/testing/sssd/0003-alpine.patch b/testing/sssd/0003-alpine.patch
index 043975d579b..d040bde1dc4 100644
--- a/testing/sssd/0003-alpine.patch
+++ b/testing/sssd/0003-alpine.patch
@@ -1,5 +1,43 @@
---- sssd-1.15.3/src/external/platform.m4
-+++ sssd-1.15.3-old/src/external/platform.m4
+diff --git a/Makefile.am b/Makefile.am
+index 426a62b29..5899cddbe 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4685,13 +4685,17 @@ else
+ if HAVE_GENTOO
+ init_SCRIPTS += \
+ src/sysv/gentoo/sssd
++else
++if HAVE_ALPINE
++ init_SCRIPTS += \
++ src/sysv/alpine/sssd
+ else
+ init_SCRIPTS += \
+ src/sysv/sssd
+ endif
+ endif
+ endif
+-
++endif
+
+ dist_sssddata_DATA = \
+ src/config/etc/sssd.api.conf \
+diff --git a/configure.ac b/configure.ac
+index 9df463d9c..7d8c436ed 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -505,7 +505,7 @@ AC_DEFINE_UNQUOTED([ABS_SRC_DIR], ["$my_srcdir"], [Absolute path to the source d
+
+ AC_CONFIG_FILES([Makefile contrib/sssd.spec src/examples/rwtab src/doxy.config
+ contrib/sssd-pcsc.rules
+- src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd
++ src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd src/sysv/alpine/sssd
+ po/Makefile.in src/man/Makefile src/tests/cwrap/Makefile
+ src/tests/intg/Makefile src/tests/test_CA/Makefile
+ src/lib/ipa_hbac/ipa_hbac.pc src/lib/ipa_hbac/ipa_hbac.doxy
+diff --git a/src/external/platform.m4 b/src/external/platform.m4
+index c67e08144..a1bb8cdaa 100644
+--- a/src/external/platform.m4
++++ b/src/external/platform.m4
@@ -1,5 +1,5 @@
AC_ARG_WITH([os],
- [AC_HELP_STRING([--with-os=OS_TYPE], [Type of your operation system (fedora|redhat|suse|gentoo)])]
@@ -7,7 +45,7 @@
)
osname=""
if test x"$with_os" != x ; then
-@@ -7,6 +7,7 @@
+@@ -7,6 +7,7 @@ if test x"$with_os" != x ; then
test x"$with_os" = xredhat || \
test x"$with_os" = xsuse || \
test x"$with_os" = xgentoo || \
@@ -15,7 +53,7 @@
test x"$with_os" = xdebian ; then
osname=$with_os
else
-@@ -25,6 +26,8 @@
+@@ -25,6 +26,8 @@ if test x"$osname" = x ; then
osname="debian"
elif test -f /etc/gentoo-release ; then
osname="gentoo"
@@ -24,7 +62,7 @@
fi
AC_MSG_NOTICE([Detected operating system type: $osname])
-@@ -35,6 +38,7 @@
+@@ -35,6 +38,7 @@ AM_CONDITIONAL([HAVE_REDHAT], [test x"$osname" = xredhat])
AM_CONDITIONAL([HAVE_SUSE], [test x"$osname" = xsuse])
AM_CONDITIONAL([HAVE_DEBIAN], [test x"$osname" = xdebian])
AM_CONDITIONAL([HAVE_GENTOO], [test x"$osname" = xgentoo])
@@ -32,59 +70,11 @@
AC_CHECK_MEMBERS([struct ucred.pid, struct ucred.uid, struct ucred.gid], , ,
[[#include <sys/socket.h>]])
---- sssd-1.15.3/Makefile.am
-+++ sssd-1.15.3-old/Makefile.am
-@@ -4423,12 +4419,16 @@
- init_SCRIPTS += \
- src/sysv/gentoo/sssd
- else
-+if HAVE_ALPINE
- init_SCRIPTS += \
-+ src/sysv/alpine/sssd
-+else
-+ init_SCRIPTS += \
- src/sysv/sssd
- endif
- endif
- endif
--
-+endif
-
- dist_sssddata_DATA = \
- src/config/etc/sssd.api.conf \
---- sssd-1.15.3-old/configure.ac
-+++ sssd-1.15.3/configure.ac
-@@ -491,7 +491,7 @@
-
- AC_CONFIG_FILES([Makefile contrib/sssd.spec src/examples/rwtab src/doxy.config
- contrib/sssd-pcsc.rules
-- src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd
-+ src/sysv/sssd src/sysv/gentoo/sssd src/sysv/SUSE/sssd src/sysv/alpine/sssd
- po/Makefile.in src/man/Makefile src/tests/cwrap/Makefile
- src/tests/intg/Makefile
- src/lib/ipa_hbac/ipa_hbac.pc src/lib/ipa_hbac/ipa_hbac.doxy
---- /dev/null
-+++ sssd-1.15.3/src/sysv/alpine/sssd
-@@ -0,0 +1,17 @@
-+#!/sbin/openrc-run
-+
-+depend(){
-+ need localmount netmount clock
-+}
-+
-+start(){
-+ ebegin "Starting sssd"
-+ start-stop-daemon --start --exec ${exec_prefix}/usr/sbin/sssd -- -Df ${SSSD_OPTIONS}
-+ eend ${?}
-+}
-+
-+stop(){
-+ ebegin "Stopping sssd"
-+ start-stop-daemon --stop --pidfile ${prefix}/var/run/sssd.pid
-+ eend ${?}
-+}
+diff --git a/src/sysv/alpine/sssd.in b/src/sysv/alpine/sssd.in
+new file mode 100644
+index 000000000..597bf8ce9
--- /dev/null
-+++ sssd-1.15.3/src/sysv/alpine/sssd.in
++++ b/src/sysv/alpine/sssd.in
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+