aboutsummaryrefslogtreecommitdiffstats
path: root/testing/stress-ng/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-17 10:39:14 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-17 10:51:18 +0000
commitf511a309aa25dda83e2163a53daf6cc646749e60 (patch)
tree59b5eec17d13e60342d9d8c340a2e07685236a84 /testing/stress-ng/APKBUILD
parent0b799b996baff1912682bcaa48eeaa477b26a0f9 (diff)
testing/stress-ng: upgrade to 0.09.57
- I think it would be nice if we keep using similar function format (curly brackets) - Don't use curly brackets in variables if not needed - Don't overuse variables. If the value doesn't change just use the value. - Proper use of $pkgver in url. (not nitpicking but an actual bug) - break after 80 chars. - don't uses extra line breaks in shell lists when not needed. - Don't cleanup directories which are already in the base system - Test are disabled due to qemu, but we are not running qemu in our environment. tests are not portable so disable them. - examples are already inside the doc path, so i guess we can just ship them with doc subpackage - doc subpkg function doesn't need to be overridden. - libc6-compat should almost be never used in apkbuild. it probable means something is broken or incorrect
Diffstat (limited to 'testing/stress-ng/APKBUILD')
-rw-r--r--testing/stress-ng/APKBUILD46
1 files changed, 10 insertions, 36 deletions
diff --git a/testing/stress-ng/APKBUILD b/testing/stress-ng/APKBUILD
index 120d9f47f5e..426597192b6 100644
--- a/testing/stress-ng/APKBUILD
+++ b/testing/stress-ng/APKBUILD
@@ -1,60 +1,34 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
pkgname=stress-ng
-pkgver=0.09.54
+pkgver=0.09.57
pkgrel=0
pkgdesc="stress-ng will stress test a computer system in various selectable ways."
url="https://kernel.ubuntu.com/~cking/stress-ng/"
arch="all"
license="GPL-2.0-or-later"
-depends="
- libc6-compat
- libgcrypt
-"
+options="!check" # tests are not portable
makedepends="
- attr-dev
- keyutils-dev
+ linux-headers
libaio-dev
libbsd-dev
- libcap-dev
- libgcrypt-dev
- linux-headers
lksctp-tools-dev
zlib-dev
"
-options="!check" # Tests are unreliable with qemu and take a long time
-subpackages="${pkgname}-doc ${pkgname}-examples"
+subpackages="$pkgname-doc"
source="
- https://kernel.ubuntu.com/~cking/tarballs/${pkgname}/${pkgname}-0.09.54.tar.xz
-
+ https://kernel.ubuntu.com/~cking/tarballs/stress-ng/stress-ng-$pkgver.tar.xz
0001-Remove-GLOB_ONLYDIR-for-musl.patch
"
-build()
-{
+build() {
make
}
-doc()
-{
- mkdir -p "${subpkgdir}/usr/share/man/"
- mv "${pkgdir}/usr/share/man/man1/" "${subpkgdir}/usr/share/man/"
- rm -r "${pkgdir}/usr/share/man/"
- rmdir "${pkgdir}/usr/share" || true
-}
-
-examples()
-{
- mkdir -p "${subpkgdir}/usr/share/doc/${pkgname}/"
- mv "${pkgdir}/usr/share/doc/${pkgname}/example-jobs/" "${subpkgdir}/usr/share/doc/${pkgname}/"
- rm -r "${pkgdir}/usr/share/doc/"
- rmdir "${pkgdir}/usr/share" || true
-}
-
-package()
-{
- make DESTDIR="${pkgdir}" JOBDIR="/usr/share/doc/${pkgname}/example-jobs/" install
+package() {
+ make DESTDIR="${pkgdir}" \
+ JOBDIR="/usr/share/doc/${pkgname}/example-jobs/" install
}
-sha512sums="d5e469772dbcabcfa3aa7296b9639de6713d48ef0f279be6df108dd94f3808f40ce13afd5c028bea08b47803cd4b92faea04cd036024c8be3e8a79b5f0850ff4 stress-ng-0.09.54.tar.xz
+sha512sums="5c3bd06be0f66a6bbb88393b3d22400b5a307e4c45e27d7cb15502370b0873ec11c911aa31fa066400152169ec5bea29c1c0260899dedbc640fbef09ee672cb5 stress-ng-0.09.57.tar.xz
8b648cdeced325a04c494e84be78182a941ce4c11327c3c0c24bff2caf399ff09a8e88ad19b564f1eb614e9cdc1560377075ec866d90d17a55cb45498b0c3a0d 0001-Remove-GLOB_ONLYDIR-for-musl.patch"