aboutsummaryrefslogtreecommitdiffstats
path: root/testing/subtitleeditor
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-23 07:57:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-23 07:58:01 +0000
commita3d88a3edf3383cf4ee6096c4da3ecbb5333a08d (patch)
tree3a3964ae0bc3f5cda5abf4fb2723faef216b045c /testing/subtitleeditor
parent913ab399a3758b18030f549fce9c96e530678b4b (diff)
testing/subtitleeditor: new aport
Diffstat (limited to 'testing/subtitleeditor')
-rw-r--r--testing/subtitleeditor/01-fix-build.patch37
-rw-r--r--testing/subtitleeditor/02-add-missing-potfiles.patch14
-rw-r--r--testing/subtitleeditor/03-fix-build-gstreamermm-1.8.0.patch43
-rw-r--r--testing/subtitleeditor/04-remove-deprecated-variable.patch20
-rw-r--r--testing/subtitleeditor/APKBUILD44
5 files changed, 158 insertions, 0 deletions
diff --git a/testing/subtitleeditor/01-fix-build.patch b/testing/subtitleeditor/01-fix-build.patch
new file mode 100644
index 00000000000..706fe65e547
--- /dev/null
+++ b/testing/subtitleeditor/01-fix-build.patch
@@ -0,0 +1,37 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Fix build
+Last-update: 2016-10-15
+--- a/src/vp/gstplayer.cc
++++ b/src/vp/gstplayer.cc
+@@ -417,8 +417,13 @@
+ }
+ catch(std::runtime_error &ex)
+ {
+- se_debug_message(SE_DEBUG_VIDEO_PLAYER, "failed to gen_audio_element '%s'", ex.what());
+- GST_ELEMENT_WARNING(m_pipeline->gobj(), RESOURCE, NOT_FOUND, (ex.what()), (NULL));
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-security"
++
++ se_debug_message(SE_DEBUG_VIDEO_PLAYER, "failed to gen_audio_element '%s'", ex.what());
++ GST_ELEMENT_WARNING(m_pipeline->gobj(), RESOURCE, NOT_FOUND, (ex.what()), (NULL));
++
++#pragma GCC diagnostic pop
+ }
+ // Return an NULL ptr
+ return Glib::RefPtr<Gst::Element>();
+@@ -507,8 +512,13 @@
+ }
+ catch(std::runtime_error &ex)
+ {
+- se_debug_message(SE_DEBUG_VIDEO_PLAYER, "failed to gen_video_element '%s'", ex.what());
+- GST_ELEMENT_ERROR(m_pipeline->gobj(), RESOURCE, NOT_FOUND, (ex.what()), (NULL));
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wformat-security"
++
++ se_debug_message(SE_DEBUG_VIDEO_PLAYER, "failed to gen_audio_element '%s'", ex.what());
++ GST_ELEMENT_WARNING(m_pipeline->gobj(), RESOURCE, NOT_FOUND, (ex.what()), (NULL));
++
++#pragma GCC diagnostic pop
+ }
+ // Return an NULL ptr
+ return Glib::RefPtr<Gst::Element>();
diff --git a/testing/subtitleeditor/02-add-missing-potfiles.patch b/testing/subtitleeditor/02-add-missing-potfiles.patch
new file mode 100644
index 00000000000..5162f608766
--- /dev/null
+++ b/testing/subtitleeditor/02-add-missing-potfiles.patch
@@ -0,0 +1,14 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Add missing source files to po/POTFILES.in
+Last-update: 2016-08-09
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -71,6 +71,8 @@
+ plugins/actions/styleeditor/styleeditor.cc
+ plugins/actions/styleeditor/styleeditor.h
+ plugins/actions/stylize/stylize.cc
++plugins/actions/template/dialog-template-save-as.ui
++plugins/actions/template/template.cc
+ plugins/actions/textcorrection/assistant-text-correction.ui
+ plugins/actions/textcorrection/capitalizationpage.h
+ plugins/actions/textcorrection/commonerrorpage.h
diff --git a/testing/subtitleeditor/03-fix-build-gstreamermm-1.8.0.patch b/testing/subtitleeditor/03-fix-build-gstreamermm-1.8.0.patch
new file mode 100644
index 00000000000..ae47fd4723c
--- /dev/null
+++ b/testing/subtitleeditor/03-fix-build-gstreamermm-1.8.0.patch
@@ -0,0 +1,43 @@
+Author: Philip Rinn <rinni@inventati.org>
+Description: Fx build with gstreamermm-1.0 1.8.0
+Last-update: 2016-10-15
+--- a/plugins/actions/keyframesmanagement/mediadecoder.h
++++ b/plugins/actions/keyframesmanagement/mediadecoder.h
+@@ -200,7 +200,7 @@
+ {
+ check_missing_plugins();
+
+- Glib::ustring error = (msg) ? msg->parse().what() : Glib::ustring();
++ Glib::ustring error = (msg) ? Glib::ustring(msg->parse_debug()) : Glib::ustring();
+
+ dialog_error(_("Media file could not be played.\n"), error);
+ // Critical error, cancel the work.
+@@ -214,7 +214,7 @@
+ {
+ check_missing_plugins();
+
+- Glib::ustring error = (msg) ? msg->parse().what() : Glib::ustring();
++ Glib::ustring error = (msg) ? Glib::ustring(msg->parse_debug()) : Glib::ustring();
+ dialog_error(_("Media file could not be played.\n"), error);
+
+ return true;
+--- a/plugins/actions/waveformmanagement/mediadecoder.h
++++ b/plugins/actions/waveformmanagement/mediadecoder.h
+@@ -200,7 +200,7 @@
+ {
+ check_missing_plugins();
+
+- Glib::ustring error = (msg) ? msg->parse().what() : Glib::ustring();
++ Glib::ustring error = (msg) ? Glib::ustring(msg->parse_debug()) : Glib::ustring();
+
+ dialog_error(_("Media file could not be played.\n"), error);
+ // Critical error, cancel the work.
+@@ -214,7 +214,7 @@
+ {
+ check_missing_plugins();
+
+- Glib::ustring error = (msg) ? msg->parse().what() : Glib::ustring();
++ Glib::ustring error = (msg) ? Glib::ustring(msg->parse_debug()) : Glib::ustring();
+ dialog_error(_("Media file could not be played.\n"), error);
+
+ return true;
diff --git a/testing/subtitleeditor/04-remove-deprecated-variable.patch b/testing/subtitleeditor/04-remove-deprecated-variable.patch
new file mode 100644
index 00000000000..6ede1f8a7b1
--- /dev/null
+++ b/testing/subtitleeditor/04-remove-deprecated-variable.patch
@@ -0,0 +1,20 @@
+Author: kitone <kitone@gna.org>
+Description: Remove deprecated gnome-common variable GNOME2_DIR
+Last-update: 2016-11-09
+--- trunk/autogen.sh
++++ trunk/autogen.sh
+@@ -5,14 +5,6 @@
+
+ DIE=0
+
+-if [ -n "$GNOME2_DIR" ]; then
+- ACLOCAL_FLAGS="-I $GNOME2_DIR/share/aclocal $ACLOCAL_FLAGS"
+- LD_LIBRARY_PATH="$GNOME2_DIR/lib:$LD_LIBRARY_PATH"
+- PATH="$GNOME2_DIR/bin:$PATH"
+- export PATH
+- export LD_LIBRARY_PATH
+-fi
+-
+ (test -f $srcdir/configure.ac) || {
+ echo -n "**Error**: Directory "\`$srcdir\'" does not look like the"
+ echo " top-level package directory"
diff --git a/testing/subtitleeditor/APKBUILD b/testing/subtitleeditor/APKBUILD
new file mode 100644
index 00000000000..b2c68e12aeb
--- /dev/null
+++ b/testing/subtitleeditor/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=subtitleeditor
+pkgver=0.53.0
+pkgrel=0
+pkgdesc="GTK+3 tool to create and edit subtitles."
+url="http://home.gna.org/subtitleeditor/"
+arch="all"
+license="GPL3"
+makedepends="libxml++-2.6-dev enchant-dev libsigc++-dev xdg-utils gtkmm3-dev gtk+3.0-dev
+ gst-plugins-base1-dev gstreamer1-dev gstreamermm-dev iso-codes-dev gst-libav1
+ desktop-file-utils gst-plugins-ugly1"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.gna.org/$pkgname/${pkgver%.[0-9]*]}/$pkgname-$pkgver.tar.gz
+ 01-fix-build.patch
+ 02-add-missing-potfiles.patch
+ 03-fix-build-gstreamermm-1.8.0.patch
+ 04-remove-deprecated-variable.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ --disable-nls
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="8787831947785885befb50221869169eda73489851389e72f34edac7a9c2c59d05ba69e86d4d2d5b3a13b2678377ee2520c110ffa472b718884dd2e711603b8b subtitleeditor-0.53.0.tar.gz
+3f15e7be92f6a182e6d7773c9ed91b3d43158618d368f14d3d138fea2addbc40e860a54d486a3a6e2f93b03c695e4a2ebf23617702eb6ba65ce5a598cb5a4dda 01-fix-build.patch
+9a80db68a271242c8925323844abcb287f7a3e966c42d593a0dc0c3ec452de8f7b9b1096c19f9e9d2dd285c2f21d404b355c84beacb1d3e3993a60e0b907ae30 02-add-missing-potfiles.patch
+184b6dabdb73e4b40ac15d38fb31fc3b58f34f87fa996fb18770a2af0dfd3e063980f3da5a8ae56145a2270e2683ede9ec890337658461182c09ac2fd4dfbfd3 03-fix-build-gstreamermm-1.8.0.patch
+d486b3cca3ec91a0fba0bc439007097689d170ba31807223d9c22fe9c236042c5734a82a87a9b245f61d5bd3554d00a5bac22f6496fe116e27a1baa2c15bfe0a 04-remove-deprecated-variable.patch"