aboutsummaryrefslogtreecommitdiffstats
path: root/testing/suitesparse/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-04 22:21:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-09 19:26:06 +0200
commit88eba5488854f436eabbdffd42cfdff587cbf884 (patch)
tree48a83a973ab1c8820c227d5d73912d443827d0d6 /testing/suitesparse/APKBUILD
parentab7d0fd6da26ee817ee94118e38545e95e38d9b9 (diff)
testing/suitesparse: new abuild
http://faculty.cse.tamu.edu/davis/suitesparse.html A collection of sparse matrix libraries
Diffstat (limited to 'testing/suitesparse/APKBUILD')
-rw-r--r--testing/suitesparse/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/suitesparse/APKBUILD b/testing/suitesparse/APKBUILD
new file mode 100644
index 00000000000..c1b1a224819
--- /dev/null
+++ b/testing/suitesparse/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=suitesparse
+_pkgname=SuiteSparse
+pkgver=4.5.3
+pkgrel=0
+pkgdesc="A collection of sparse matrix libraries"
+url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+arch="x86 x86_64"
+license="GPL"
+depends_dev="openblas-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://faculty.cse.tamu.edu/davis/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 0001-exclude-metis.patch
+ 0002-remove-rpath.patch
+ "
+builddir="$srcdir/$_pkgname"
+
+prepare() {
+ cd "$builddir"
+
+ # OpenBLAS provides also LAPACK.
+ export LAPACK="-lopenblas"
+
+ # gcc fails on internal error when using default -O3.
+ export OPTIMIZATION="-O2"
+
+ # Do not include the Partition module and METIS (it's optional and
+ # Julia doesn't need it).
+ export CFLAGS="$CFLAGS -DNPARTITION"
+ rm -r metis-*
+
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+
+ make library
+}
+
+package() {
+ cd "$builddir"
+
+ make install \
+ INSTALL="$pkgdir/usr" \
+ INSTALL_INCLUDE="$pkgdir/usr/include/$pkgname" \
+ INSTALL_DOC="$pkgdir/usr/share/doc/$pkgname"
+}
+
+md5sums="8ec57324585df3c6483ad7f556afccbd SuiteSparse-4.5.3.tar.gz
+308b4f96e82d7f5c92335ca6c7c74251 0001-exclude-metis.patch
+ce5696f96435db0125ac1815888fb7f6 0002-remove-rpath.patch"
+sha256sums="6199a3a35fbce82b155fd2349cf81d2b7cddaf0dac218c08cb172f9bc143f37a SuiteSparse-4.5.3.tar.gz
+06f825ed80f73c30d71439650b951ea835a6139fe2e30078ed155fdecc7606ab 0001-exclude-metis.patch
+4db04c59039e9fe50f75d00fb662eaffbd76ede498ff8ec8858b697df2679e32 0002-remove-rpath.patch"
+sha512sums="88a5ba6c70e4d66751d1ac32fd8998cde11509e7b034814c34757180db70ce2838ebb77fd7c617bf96e473214c70ccbdd0064b4f5e4dd69ae4c51dfeb9696496 SuiteSparse-4.5.3.tar.gz
+aa2d62a371eefb33f0c81d3f7b50cf36e76c4f010fb5bb424e5e7344a1921cb6a430742ebb92df42cef587ec46ad8d2b777d3d9a62eb4a128e02bee8ad5de272 0001-exclude-metis.patch
+cd40b696515b26c95298b435a5111e582dc42c2fa2e8ef9889558467d375b1d19452838b9463df66958e73ddb0c8c0191936e3e952586a3c7d345edb08fa7e62 0002-remove-rpath.patch"