summaryrefslogtreecommitdiffstats
path: root/testing/tcpreplay
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:02:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:03:42 +0000
commit95556218aa50c9edfa51531d89938fec9c9190b3 (patch)
tree979087d5e85232f86b675708f8d2fb6d37b433b4 /testing/tcpreplay
parentcb8a398421d7648bf608d182b9ff631332fc3541 (diff)
testing/tcpreplay: build fix for musl
Diffstat (limited to 'testing/tcpreplay')
-rw-r--r--testing/tcpreplay/APKBUILD14
-rw-r--r--testing/tcpreplay/musl-socklen_t.patch13
2 files changed, 22 insertions, 5 deletions
diff --git a/testing/tcpreplay/APKBUILD b/testing/tcpreplay/APKBUILD
index e5af8cc6097..5955e97e580 100644
--- a/testing/tcpreplay/APKBUILD
+++ b/testing/tcpreplay/APKBUILD
@@ -12,7 +12,9 @@ depends_dev=""
makedepends="libdnet-dev libpcap-dev tcpdump"
install=""
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ musl-socklen_t.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -34,7 +36,6 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-dynamic-link \
- --enable-tcpreplay-edit \
--enable-local-libopts \
--disable-libopts-install \
|| return 1
@@ -47,6 +48,9 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="b8838e2d5142da95414e40793e8d912f tcpreplay-4.0.2.tar.gz"
-sha256sums="afb14a0b401b562ed447774edbc44522dd0392a1deec8a0f8a03d3bda3b6bf2d tcpreplay-4.0.2.tar.gz"
-sha512sums="b70f5caf2ce653ee05c4c730d348b0acea5b98de91f89b9b7af3473714618e6520a3457cf60ce033fc5df2ef2ca8fe314e9ee066947ffe73ca75805000a56eaf tcpreplay-4.0.2.tar.gz"
+md5sums="b8838e2d5142da95414e40793e8d912f tcpreplay-4.0.2.tar.gz
+c83ee833bf47b4ec5ec56e4d994d96a9 musl-socklen_t.patch"
+sha256sums="afb14a0b401b562ed447774edbc44522dd0392a1deec8a0f8a03d3bda3b6bf2d tcpreplay-4.0.2.tar.gz
+6afb4d55418f5a55509b66f7cc26dba2aad9b03e147d9d97eafaf822cb77c283 musl-socklen_t.patch"
+sha512sums="b70f5caf2ce653ee05c4c730d348b0acea5b98de91f89b9b7af3473714618e6520a3457cf60ce033fc5df2ef2ca8fe314e9ee066947ffe73ca75805000a56eaf tcpreplay-4.0.2.tar.gz
+b6adb38a0d765ac531839ef189165ef50bae9c2d6f056c6108fe7618cf948388e0f97331a77d304c838021dddbb520bdc5c7384b6da01f85d8c0a45f37d85c2d musl-socklen_t.patch"
diff --git a/testing/tcpreplay/musl-socklen_t.patch b/testing/tcpreplay/musl-socklen_t.patch
new file mode 100644
index 00000000000..b4afb34040d
--- /dev/null
+++ b/testing/tcpreplay/musl-socklen_t.patch
@@ -0,0 +1,13 @@
+--- ./src/common/sendpacket.c.orig
++++ ./src/common/sendpacket.c
+@@ -166,10 +166,6 @@
+ #include "txring.h"
+ #endif
+
+-#ifndef __GLIBC__
+-typedef int socklen_t;
+-#endif
+-
+ static sendpacket_t *sendpacket_open_pf(const char *, char *);
+ static struct tcpr_ether_addr *sendpacket_get_hwaddr_pf(sendpacket_t *);
+ static int get_iface_index(int fd, const char *device, char *);