aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thermald/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-10-30 15:11:48 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-10-30 15:13:38 +0100
commiteac46e4fe78b7c5d07a8ab92e95fe60f2cb58f34 (patch)
tree1af16e825de162eb5a82b05f51db82bd16e3dc7d /testing/thermald/APKBUILD
parent2a9ec6be775eed4cbb03abe943fb2860a87fc087 (diff)
testing/thermald: improve abuild, remove useless systemd config
Diffstat (limited to 'testing/thermald/APKBUILD')
-rw-r--r--testing/thermald/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/thermald/APKBUILD b/testing/thermald/APKBUILD
index 030dde9fa59..75b94c24de2 100644
--- a/testing/thermald/APKBUILD
+++ b/testing/thermald/APKBUILD
@@ -1,6 +1,7 @@
# Contributor: mellotron <mellotron@tutanota.com>
# Maintainer:
pkgname=thermald
+_pkgname=thermal_daemon
pkgver=1.5.3
pkgrel=0
pkgdesc="Thermal daemon for IA"
@@ -8,16 +9,15 @@ url="https://github.com/01org/thermal_daemon"
arch="all"
license="GPL2"
depends=""
-depends_dev=""
makedepends="autoconf automake libtool dbus-glib-dev libxml2-dev linux-headers"
-install=""
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/01org/thermal_daemon/archive/v$pkgver.tar.gz
- thermald.initd"
+source="$pkgname-$pkgver.tar.gz::https://github.com/01org/$_pkgname/archive/v$pkgver.tar.gz
+ thermald.initd"
+builddir="$srcdir/$_pkgname-$pkgver"
-builddir="$srcdir/thermal_daemon-$pkgver"
build() {
cd "$builddir"
+
./autogen.sh
./configure \
--build=$CBUILD \
@@ -32,12 +32,14 @@ build() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install || return 1
- rm -rf "$pkgdir"/etc/init/
+ rm -rf "$pkgdir"/etc/init/ "$pkgdir"/etc/dbus-1
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname || return 1
}
+
md5sums="66402236ed3c86a798029cb4d5313817 thermald-1.5.3.tar.gz
a1e252054ecdc987cf641df912b9a220 thermald.initd"
sha256sums="e20b450ef27a5b5e45474c831663c8f5ecd14c82ace5a4b1e06c442e0a23b53e thermald-1.5.3.tar.gz