aboutsummaryrefslogtreecommitdiffstats
path: root/testing/thonny/APKBUILD
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-05-20 14:22:13 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-21 07:46:25 +0000
commitaa5658215db70e7ce51934c2cdab2eb9fd4b01be (patch)
treeed735234a1bf8e5244501c79fd6da4bf078f4044 /testing/thonny/APKBUILD
parent98b324e9a2170e218932316000b4d8b5c8c77b08 (diff)
testing/thonny: new aport
https://thonny.org Python IDE for beginners
Diffstat (limited to 'testing/thonny/APKBUILD')
-rw-r--r--testing/thonny/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/thonny/APKBUILD b/testing/thonny/APKBUILD
new file mode 100644
index 00000000000..5d9700df202
--- /dev/null
+++ b/testing/thonny/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+pkgname=thonny
+pkgver=3.2.7
+pkgrel=0
+pkgdesc="Python IDE for beginners"
+url="https://thonny.org"
+arch="noarch"
+license="MIT"
+depends="
+ openssl
+ py3-astroid
+ py3-asttokens
+ py3-docutils
+ py3-jedi
+ py3-mypy
+ py3-pylint
+ py3-pyperclip
+ py3-pyserial
+ py3-send2trash
+ py3-toml
+ python3-tkinter
+ "
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/t/thonny/thonny-3.2.7.tar.gz"
+options="!check" # Tests need a DISPLAY
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="0675763a23b635e94a0f01a5646099e338106791b5b61b757740ea8762fdeda2efba4485ffe23a8b3620be573ca5c49f9e3c4c94baf64ca7b45969318d324bc5 thonny-3.2.7.tar.gz"