aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tiptop
diff options
context:
space:
mode:
authorMitch Tishmack <mitch.tishmack@gmail.com>2017-05-14 15:27:04 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 17:58:58 +0000
commitdbd2615d67beda10a0f7c015e560a5f3da4f2a79 (patch)
tree28c048cebf04e36cb401474a486154cf9353a57f /testing/tiptop
parent3a53720f60e3e88d19e634112e47da44cfe4655b (diff)
testing/tiptop: new abuild
Diffstat (limited to 'testing/tiptop')
-rw-r--r--testing/tiptop/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/tiptop/APKBUILD b/testing/tiptop/APKBUILD
new file mode 100644
index 00000000000..d57ab3033d5
--- /dev/null
+++ b/testing/tiptop/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=tiptop
+pkgver=2.3
+pkgrel=0
+pkgdesc="Tiptop: Hardware Performance Counters for the Masses"
+url="http://tiptop.gforge.inria.fr"
+# Note: This tool requires two things to work:
+# 1: hardware counters in the cpu itself
+# 2: support in the kernel perf framework to use them
+#
+# Right now this applies to x86 only. Note this tool will compile
+# elsewhere but without the aforementioned hardware support and kernel
+# support, nothing of use will happen when run.
+arch="x86 x86_64"
+license="GPL2"
+makedepends="byacc flex linux-headers ncurses-dev libxml2-dev"
+subpackages="$pkgname-doc"
+source="http://$pkgname.gforge.inria.fr/releases/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+# Note, arg parsing appears to happen after attempting a perf syscall
+# so while it would be nice to run tiptop -h to validate the compile worked
+# there is a chance it might error out for no reason than the system building
+# not having support for the syscall or hardware.
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+sha512sums="e09ad1fd7063c9b8b7351b5c114cfa1f8e1737b1cfb73c4c869612c3887b060a838c33bdee330349225b48cd73d295fef24cd36c6eb36b566d20adff2dae53d5 tiptop-2.3.tar.gz"