aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ttf-cantarell/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-08 02:17:51 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-08 02:17:51 +0000
commit880887608d37f5ea2b5428cbfe721d8054b83660 (patch)
tree0caf635f36547a21ac49bde06fea97145593de59 /testing/ttf-cantarell/APKBUILD
parent0dc544cd56b8350bdb01ae2b09a3bf388ddf899f (diff)
testing/ttf-cantarell: new aport
Diffstat (limited to 'testing/ttf-cantarell/APKBUILD')
-rw-r--r--testing/ttf-cantarell/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/ttf-cantarell/APKBUILD b/testing/ttf-cantarell/APKBUILD
new file mode 100644
index 00000000000..596aafdeaf2
--- /dev/null
+++ b/testing/ttf-cantarell/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=ttf-cantarell
+pkgver=0.0.25
+pkgrel=0
+pkgdesc="GNOME default font"
+url="https://wiki.gnome.org/Projects/CantarellFonts"
+arch="noarch"
+license="Custom"
+depends=""
+makedepends=""
+install=""
+install_if="gnome-shell"
+subpackages=""
+source="http://ftp.gnome.org/pub/GNOME/sources/cantarell-fonts/${pkgver%.*}/cantarell-fonts-$pkgver.tar.xz"
+builddir="$srcdir/cantarell-fonts-$pkgver"
+
+# it's just data, no testsuites
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c09c3ecb3d4c50f613234398fabd327ca92b8abbc27082e8e98f2944f3dd9f0c2ff4c022ff5e5503a86e724bb8e2fbf6cd081f8a29e91b4209f5bf0e32168c3e cantarell-fonts-0.0.25.tar.xz"