aboutsummaryrefslogtreecommitdiffstats
path: root/testing/tvheadend-git
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-05-13 00:33:16 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-05-13 00:33:21 +0200
commita78e8b8b56e1195ccb513ece4461567c2e6238d7 (patch)
treea26adac9c7e37cd57b9477897244413532af2702 /testing/tvheadend-git
parent204c8cc0980353ed4d635612799585ff8e9168a2 (diff)
testing/tvheadend-git: new snapshot
Diffstat (limited to 'testing/tvheadend-git')
-rw-r--r--testing/tvheadend-git/0001-replace-pthread_yield-with-POSIX-sched_yield.patch26
-rw-r--r--testing/tvheadend-git/APKBUILD55
2 files changed, 54 insertions, 27 deletions
diff --git a/testing/tvheadend-git/0001-replace-pthread_yield-with-POSIX-sched_yield.patch b/testing/tvheadend-git/0001-replace-pthread_yield-with-POSIX-sched_yield.patch
new file mode 100644
index 00000000000..d57a5f7e4e7
--- /dev/null
+++ b/testing/tvheadend-git/0001-replace-pthread_yield-with-POSIX-sched_yield.patch
@@ -0,0 +1,26 @@
+From 54df37222a72233b471fa44ee8d2beaff0d2dfd8 Mon Sep 17 00:00:00 2001
+From: Carlo Landmeter <clandmeter@gmail.com>
+Date: Fri, 13 May 2016 00:24:14 +0200
+Subject: [PATCH] replace pthread_yield with POSIX sched_yield
+
+See: http://linux.die.net/man/3/pthread_yield
+---
+ src/api/api_idnode.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/api/api_idnode.c b/src/api/api_idnode.c
+index fa9edb3..eb41646 100644
+--- a/src/api/api_idnode.c
++++ b/src/api/api_idnode.c
+@@ -651,7 +651,7 @@ api_idnode_handler
+ }
+ pthread_mutex_unlock(&global_lock);
+ if (destroyed)
+- pthread_yield(); /* delete penalty */
++ sched_yield(); /* delete penalty */
+ }
+ htsmsg_destroy(msg);
+
+--
+2.8.2
+
diff --git a/testing/tvheadend-git/APKBUILD b/testing/tvheadend-git/APKBUILD
index d07bf0e14a2..f20964af5fb 100644
--- a/testing/tvheadend-git/APKBUILD
+++ b/testing/tvheadend-git/APKBUILD
@@ -2,8 +2,8 @@
pkgname=tvheadend-git
verbase=4.1
# stable versions have an even minor version number
-pkgver=4.1_git20160315
-pkgrel=1
+pkgver=4.1_git20160512
+pkgrel=0
pkgdesc="TV Streaming server for linux"
url="http://tvheadend.org/"
arch="all"
@@ -12,7 +12,7 @@ depends=""
depends_dev=""
makedepends="$depends_dev findutils bash git python linux-headers wget
bsd-compat-headers coreutils openssl-dev ffmpeg-dev gettext-dev
- libhdhomerun-dev"
+ libhdhomerun-dev cmake"
pkgusers="tvheadend"
pkggroups="tvheadend"
install="$pkgname.pre-install"
@@ -20,25 +20,16 @@ subpackages="$pkgname-doc $pkgname-dvb-scan:dvb_scan $pkgname-satellites-xml:sat
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- satellites.xml"
+ satellites.xml
+ 0001-replace-pthread_yield-with-POSIX-sched_yield.patch"
giturl="https://github.com/tvheadend/tvheadend.git"
disturl="dev.alpinelinux.org:/archive/$pkgname"
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -46,14 +37,21 @@ build() {
--localstatedir=/var \
--enable-libav \
--enable-hdhomerun_client \
- --disable-libffmpeg_static \
--disable-hdhomerun_static \
- || return 1
+ --disable-ffmpeg_static \
+ --disable-libx264_static \
+ --disable-libx265_static \
+ --disable-libvpx_static \
+ --disable-libtheora_static \
+ --disable-libvorbis_static \
+ --disable-libfdkaac_static \
+ --disable-libmfx_static \
+ || return 1
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install || return 1
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname || return 1
@@ -67,7 +65,7 @@ dvb_scan() {
pkgdesc="$pkgname dvb scan files"
depends="$pkgname !$pkgname-satellites_xml"
arch="noarch"
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$subpkgdir"/usr/share/tvheadend/data
mv "$pkgdir"/usr/share/tvheadend/data/dvb-scan \
"$subpkgdir"/usr/share/tvheadend/data || return 1
@@ -77,22 +75,25 @@ satellites_xml() {
pkgdesc="$pkgname sattelites from http://satellites-xml.eu"
depends="$pkgname !$pkgname-dvb_scan"
arch="noarch"
- cd "$_builddir"
+ cd "$builddir"
mkdir -p "$subpkgdir"/usr/share/tvheadend/data/dvb-scan/dvb-s
msg "Generating sattelites from satellites.xml"
support/sat_xml_scan.py "$srcdir"/satellites.xml \
"$subpkgdir"/usr/share/tvheadend/data/dvb-scan/dvb-s || return 1
}
-md5sums="75f0152b15635d4fa2f4eafb28f55cee tvheadend-git-4.1_git20160315.tar.gz
+md5sums="f3538292f1d203631b99e118ee6245d3 tvheadend-git-4.1_git20160512.tar.gz
b2f3e611fb9c6c7013cc6e808dcb155c tvheadend-git.initd
a29e609cc5f02c34812df253aa7bf623 tvheadend-git.confd
-84e9f5d3446be49624303cbef43a2523 satellites.xml"
-sha256sums="a6defcdd2d1c6dfa26e699adda0ea089f1b72ab490447cf68a37da2c650a3e00 tvheadend-git-4.1_git20160315.tar.gz
+84e9f5d3446be49624303cbef43a2523 satellites.xml
+e6f4527ed2abecfb1c4baf3360036207 0001-replace-pthread_yield-with-POSIX-sched_yield.patch"
+sha256sums="fbfecc1f8a63eaaf877c99075d728d7434ea7481c7f7332b940295f2012ff458 tvheadend-git-4.1_git20160512.tar.gz
ca245780931d2507f40b8ed13a9fad44550243dda1ade863ac0fd5316716a992 tvheadend-git.initd
1fd4b100142ba9d7aa9b73d3168b3c015abd786894c6a284e9ecabae421d2cb9 tvheadend-git.confd
-63e8a27474d88b821c5768b59043620ff92e0a4d2d8a87290d1a2ef2e3f8c39b satellites.xml"
-sha512sums="a5a19992c29aafab4aae288fa5aedb4f18812c32c1978374ed72419fb46e1ed2e420a9572dd3ce18b684b5b24e0a46b6964dce0aa493746924e482b69d69d7a8 tvheadend-git-4.1_git20160315.tar.gz
+63e8a27474d88b821c5768b59043620ff92e0a4d2d8a87290d1a2ef2e3f8c39b satellites.xml
+26806588a76151c5f54a3fc59d72b7fcc6bc35e7ea137a866a86a36db288d0a3 0001-replace-pthread_yield-with-POSIX-sched_yield.patch"
+sha512sums="29c21c3642fc0e668c223ac687dc5119918b7bbb9c5172a5c0b6005861ef1d3d182928e83c799704455f29ae909aa387c47bfb2293c0a00a1fb14bd287330f58 tvheadend-git-4.1_git20160512.tar.gz
db275e263d52d0515544cc52836d99d1cf43b7c17a8037f897d5788e770b69be85cb709f71e7fae4d66c4a2cef8c4f9533fc2ab41490776ee437e4db4d27fa31 tvheadend-git.initd
dd55c56ffb0b090fc03537556340ac0dd17741d2ce9eeabb388af43b566e2764385affc2e4457fa7a6d94e44c491d7cf43c6b6d89dc1ba60dd9724cc488c0ef1 tvheadend-git.confd
-38eb39ecdc0a165b18bab5dcd236a89f44b1e7c77e224612e45a50b3b8b2a6b20e72cdf3fe2ef75278b4c515906b75f547c8e1e7c86fef1712437bbbb7a0caeb satellites.xml"
+38eb39ecdc0a165b18bab5dcd236a89f44b1e7c77e224612e45a50b3b8b2a6b20e72cdf3fe2ef75278b4c515906b75f547c8e1e7c86fef1712437bbbb7a0caeb satellites.xml
+7afef4d3360841f324ac1ba198ea2c3389cb84a9c3173700dfbde48620667fdee9208a319ceb697f81dbfe3500f2b1352bccfd0a34fdeb9ae22eff9ff333152f 0001-replace-pthread_yield-with-POSIX-sched_yield.patch"