aboutsummaryrefslogtreecommitdiffstats
path: root/testing/txt2tags/APKBUILD
diff options
context:
space:
mode:
authorOliver Smith <ollieparanoid@postmarketos.org>2020-09-10 12:40:57 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-11 01:16:30 +0000
commitce5511e53cdd611f0a77399170dab46c929ab158 (patch)
tree2a8ac371221f5f568446a3d25c268a13cd14ce0b /testing/txt2tags/APKBUILD
parentfdf983b57bf85ac1eb76d530e7c8bb284874fde3 (diff)
testing/txt2tags: new aport
Diffstat (limited to 'testing/txt2tags/APKBUILD')
-rw-r--r--testing/txt2tags/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/txt2tags/APKBUILD b/testing/txt2tags/APKBUILD
new file mode 100644
index 00000000000..326d7cf5f98
--- /dev/null
+++ b/testing/txt2tags/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Oliver Smith <ollieparanoid@postmarketos.org>
+# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
+pkgname=txt2tags
+pkgver=3.7
+pkgrel=0
+pkgdesc="Text formatting and conversion tool"
+url="https://www.txt2tags.org"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python3 py3-setuptools"
+checkdepends="py3-tox bash"
+source="txt2tags-$pkgver.tar.gz::https://github.com/txt2tags/txt2tags/archive/3.7.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ tox --sitepackages -e py3
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="70f6b72b9555b881149e29581a200bf5195d740ca134fffb9faab3a8a04909173f40fe7758659bde44efa9aa50e9816e7164d8164f84b2046de500a49906072b txt2tags-3.7.tar.gz"