summaryrefslogtreecommitdiffstats
path: root/testing/uhttpmock
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-24 07:17:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-24 08:08:38 +0000
commitd80398782949c7b051fbb09f885f5e44218ce683 (patch)
tree5052067827107e029ffa6b82ef17456e493b5908 /testing/uhttpmock
parent4203bfe39a23aeb192ce516799cd4306494de687 (diff)
testing/uhttpmock: new aport
HTTP web service mocking library http://gitorious.org/uhttpmock/
Diffstat (limited to 'testing/uhttpmock')
-rw-r--r--testing/uhttpmock/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/uhttpmock/APKBUILD b/testing/uhttpmock/APKBUILD
new file mode 100644
index 00000000000..0a1a2f285be
--- /dev/null
+++ b/testing/uhttpmock/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=uhttpmock
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="HTTP web service mocking library"
+url="http://gitorious.org/uhttpmock/"
+arch="all"
+license="LGPLv2"
+depends=""
+depends_dev="libsoup-dev glib-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://tecnocode.co.uk/downloads/uhttpmock/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/uhttpmock-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e79bfb0d51c4de4058a2f4103dc0cd6b uhttpmock-0.2.0.tar.xz"
+sha256sums="6bc8df4cb2e0484a029ae159becc20b3df3dcc4c0ea493d25e9e2b4ab8a39e93 uhttpmock-0.2.0.tar.xz"
+sha512sums="9d69b484009679f61f2431b7ec6406c75fdcc91f040d76de2ba364456f5865e64468d6857bff2721494bd39da6006395078c129af8491b97af077fa61b59ba76 uhttpmock-0.2.0.tar.xz"