aboutsummaryrefslogtreecommitdiffstats
path: root/testing/unrealircd/APKBUILD
diff options
context:
space:
mode:
authorAlex Yam <alex@alexyam.com>2021-11-29 12:33:59 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2021-12-05 19:37:47 +0000
commit4b23f984539033c7fb44e60e5d07376da46618c5 (patch)
treeecb7bb7a36bb77ad8a4a502c3e509febcfbad84b /testing/unrealircd/APKBUILD
parent827b45aaef026fb3b0400d4f285892e70babc64b (diff)
testing/unrealircd: upgrade to 5.2.2
Diffstat (limited to 'testing/unrealircd/APKBUILD')
-rwxr-xr-xtesting/unrealircd/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/testing/unrealircd/APKBUILD b/testing/unrealircd/APKBUILD
index 85b2f9c7939..b46c4ec7420 100755
--- a/testing/unrealircd/APKBUILD
+++ b/testing/unrealircd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alex Yam <alex@alexyam.com>
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=unrealircd
-pkgver=5.0.8
+pkgver=5.2.2
pkgrel=0
pkgdesc="internet relay chat daemon (ircd)"
url="https://www.unrealircd.org/"
@@ -12,20 +12,20 @@ makedepends="
c-ares-dev
curl-dev
libnsl-dev
+ libsodium-dev
openssl-dev
pcre2-dev
tre-dev
"
subpackages="$pkgname-doc"
options="!check" # no test suite
-source="https://www.unrealircd.org/downloads/unrealircd-$pkgver.tar.gz"
+source="https://www.unrealircd.org/downloads/unrealircd-$pkgver.tar.gz
+ 0001.configure-without-running-config.patch"
prepare() {
default_prepare
update_config_guess
update_config_sub
- # Patch ./configure to run without first running ./Config
- sed -i 's/test "x$enable_dynamic_/test "$enable_dynamic_/' ./configure
}
build() {
@@ -51,12 +51,14 @@ build() {
}
package() {
- mkdir -p $pkgdir/usr/lib/unrealircd/scripts
- mkdir -p $pkgdir/var/lib/unrealircd/run
- mkdir -p $pkgdir/usr/lib/unrealircd/private_lib
+ install -dm755 \
+ $pkgdir/var/lib/unrealircd/run \
+ $pkgdir/usr/lib/unrealircd/scripts \
+ $pkgdir/usr/lib/unrealircd/private_lib
make DESTDIR="$pkgdir" install
- #remove symlink to source
+ # remove symlink to source
rm -v $pkgdir/usr/lib/unrealircd/scripts/source
}
-sha512sums="45fc0758a870dbb9c3ff55fc7029d1ecff9dcf65680f31ff331f012efbf9c9bffa60a6fe27b9bab69302d26b8293a1089cfaf1c550a3f2802a549f25e4644770 unrealircd-5.0.8.tar.gz"
+sha512sums="9d36eb1567431bc4a5420bc830bfc8dc89daa08ed1746efd6102e5ef161f67baf52e75e373454df7df6a443c4f575fb300d3c289d4dd99239a6de7d2b2a555a0 unrealircd-5.2.2.tar.gz
+532cb2419d2b79685a391113cf1f498417ff46ad545b41e3b9e2153966ba92e21e2ef8dc9010ab491bbc10c7758d38a61a1213caf7eabe1c066ccd12c0a6f13e 0001.configure-without-running-config.patch"