aboutsummaryrefslogtreecommitdiffstats
path: root/testing/uwsgi/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 20:54:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 20:54:51 +0000
commit2f5fa4664c4f4e25181a71ff032fe9fdb0bb5e35 (patch)
tree5ef2a216d30e16b6418f04126ef667cbd79e8740 /testing/uwsgi/APKBUILD
parent171ac82c086daabeed1718ed036291caa3bf8954 (diff)
testing/uwsgi: add init.d script
Diffstat (limited to 'testing/uwsgi/APKBUILD')
-rw-r--r--testing/uwsgi/APKBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/testing/uwsgi/APKBUILD b/testing/uwsgi/APKBUILD
index 7bcc28613be..c724f1b38a0 100644
--- a/testing/uwsgi/APKBUILD
+++ b/testing/uwsgi/APKBUILD
@@ -1,15 +1,18 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=1.4.8
-pkgrel=1
+pkgrel=2
pkgdesc="uWSGI application container server"
url=http://projects.unbit.it/uwsgi/
arch=all
license=GPL-2
makedepends="linux-headers lua-dev python python-dev zeromq-dev"
subpackages="uwsgi-lua uwsgi-python:py"
-source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz futimes.patch include-sched.patch lua-cache-update.patch"
+source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
+ futimes.patch include-sched.patch lua-cache-update.patch
+ uwsgi.initd uwsgi.confd
+ "
_builddir=$srcdir/$pkgname-$pkgver
prepare() {
@@ -47,6 +50,11 @@ package() {
local libdir=$pkgdir/usr/lib/uwsgi
install -d "$libdir"
install *_plugin.so "$libdir"
+
+ install -Dm755 "$srcdir"/uwsgi.initd \
+ "$pkgdir"/etc/init.d/uwsgi || return 1
+ install -Dm644 "$srcdir"/uwsgi.confd \
+ "$pkgdir"/etc/conf.d/uwsgi || return 1
}
lua() {
@@ -66,12 +74,18 @@ py() {
md5sums="10af354eccaae9c447bd5bdc69bcce12 uwsgi-1.4.8.tar.gz
2c9aeb5b2adf1fa45ef4ed6bda47236a futimes.patch
02c43e001d5f44eb421079e17f9db003 include-sched.patch
-3bba1063b54043561f520d6986e35057 lua-cache-update.patch"
+3bba1063b54043561f520d6986e35057 lua-cache-update.patch
+8a8be061d7b5f3108a0f16813da68389 uwsgi.initd
+3d6afe6a8c52556d1d6c52384fc38d9a uwsgi.confd"
sha256sums="3c35893927a065ed89775cf5a8f66f66d71b060618f4611efbcca76e520aac37 uwsgi-1.4.8.tar.gz
9ad8375325195e577e6b91a1cf7539817b58fbb4efef248d01a4b704a0e8749f futimes.patch
25cb58a02a9f1f62be227592a31152e960f51d44a9e9d14751375a9468152e90 include-sched.patch
-fe79c823399c750618572531e8c9ccfa2394da329ce16516af79887f493c1a2d lua-cache-update.patch"
+fe79c823399c750618572531e8c9ccfa2394da329ce16516af79887f493c1a2d lua-cache-update.patch
+58b998b025e4a9df20ca917bc93e287f9a8cf02d278d513fa461f70e1d08f799 uwsgi.initd
+4cb047e311aecd0f498da1d6a4c0947dd6dc7cc98575d54cb2ef150cacf8425c uwsgi.confd"
sha512sums="7ead90c0740db0ebc28256b312a98e8de610b62cc82504c738cc2f3d2b0819ae673eb1875ea31abc3e511dc76db9af9fb15f4d1ae2a62f6b67b2a5966cfe2bab uwsgi-1.4.8.tar.gz
9e867a3483197adb5ab99334d0e9f092dab44201ddbead99a4649309fd0584e6793531a147e096459984d26d0a73754688426df1fb4686c041d3889f3d29fdef futimes.patch
d454dcc5ee0a121ff44584e0da98055e6596e8a750315fe4ce6a5fbc615697b2a19b9b32c51ac9878587a855ec3f072e87a3e4e097a8b743699f58ed0d84ec0f include-sched.patch
-baf97b56448c8a38334036b11c4fb36805ccfb3b867443afe3b1ee5b91bf10981d61f690184e51fa9e492b6318b657530e2f3f11d803dce17cef1a16c56719ab lua-cache-update.patch"
+baf97b56448c8a38334036b11c4fb36805ccfb3b867443afe3b1ee5b91bf10981d61f690184e51fa9e492b6318b657530e2f3f11d803dce17cef1a16c56719ab lua-cache-update.patch
+ab9dc6277bd05821287f6f8beb3ac2504f0e41db38e11b4d2884ac026f14ac7bfaaca138f045afa712d4f2843f94de105bf0d43fad35d18679ac33b507cd187e uwsgi.initd
+9f00afb2aa574bbc59040f945475712b8c40da0c06eeb5699de5510aa116148e35ab0429fa891084cf0cd7868876d5a80e1601b7c85d0e2e9ea2a1f54cdde619 uwsgi.confd"