aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vdpauinfo/APKBUILD
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2017-06-29 20:37:13 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 05:38:59 +0000
commitf39909dd7ee301df7218587bcc643c24490144dc (patch)
treeaeb9ed519e262e8546482c296c719827d761157b /testing/vdpauinfo/APKBUILD
parentc48514a4a8b5c5466d4383e89dc7f9c4aa525d5f (diff)
testing/vdpauinfo: new aport
https://cgit.freedesktop.org/vdpau/vdpauinfo Command line utility for querying the capabilities of a VDPAU device. [TT: Remove check() and --disable-nls]
Diffstat (limited to 'testing/vdpauinfo/APKBUILD')
-rw-r--r--testing/vdpauinfo/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/vdpauinfo/APKBUILD b/testing/vdpauinfo/APKBUILD
new file mode 100644
index 00000000000..d79fe6d615d
--- /dev/null
+++ b/testing/vdpauinfo/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Taner Tas <taner76@gmail.com>
+pkgname=vdpauinfo
+pkgver="1.0"
+pkgrel=0
+pkgdesc="Command line utility for querying the capabilities of a VDPAU device."
+url="https://cgit.freedesktop.org/vdpau/vdpauinfo"
+arch="all"
+license="custom"
+makedepends="libx11-dev libvdpau-dev"
+source="https://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz"
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="54c177424bdae65374a13c0546ecda0e25e7357f9e779fb48dc018a9c11593039f87715ea18b320684dca22455df9b41a4eea6b0f977956efb6ab85b8b99297e vdpauinfo-1.0.tar.gz"