aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vifm-colors
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-08-13 21:17:50 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-08-13 21:22:36 +0200
commit25fb199b8c4103e4f59228033e9b8283b652bee4 (patch)
tree86d267b7249f58e5304fced05fa01a8fd9440881 /testing/vifm-colors
parentc98f545cc70b08a8d653579aa5200aa0a9f2b83b (diff)
testing/vifm-colors: new aport
extra colors (themes) for vifm file manager/explorer
Diffstat (limited to 'testing/vifm-colors')
-rw-r--r--testing/vifm-colors/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/vifm-colors/APKBUILD b/testing/vifm-colors/APKBUILD
new file mode 100644
index 00000000000..3cb2a96ae9a
--- /dev/null
+++ b/testing/vifm-colors/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=vifm-colors
+pkgver=0.9
+pkgrel=0
+pkgdesc=i"various colorschemes for vifm file explorer"
+url="https://github.com/vifm/vifm-colors"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # package does not have tests
+source="$pkgname-$pkgver.tar.gz::https://github.com/vifm/vifm-colors/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+package() {
+ theme="Default darkdesert g80 matrix near-default snowwhite"
+ theme="$theme astrell desert lucius mc-like ph semidarkdesert solarized-dark"
+ theme="$theme zenburn zenburn_1"
+ for i in $theme; do
+ install -Dm644 "$i.vifm" "$pkgdir/usr/share/vifm/colors/$i.vifm"
+ done
+}
+
+sha512sums="d935f34ba939106928bbe794484e114c6853252ac3fbf38fc4d832f383ec7b106230d392489f66eedf01f92ae816df1ca5503d9728e4bfe09da56a89bc79a351 vifm-colors-0.9.tar.gz"