aboutsummaryrefslogtreecommitdiffstats
path: root/testing/vis/fortify-source.patch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-02-27 17:25:08 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-02-27 17:44:22 +0100
commit9059702acc5e1a1a7e98f7ec75b4e01d0415c866 (patch)
tree927dd7bfafda7025cb9e57d2a150090e1dc2e1e3 /testing/vis/fortify-source.patch
parent70af635d68e71a24e1700fa2e0990390b43dd37a (diff)
testing/vis: new aport
Diffstat (limited to 'testing/vis/fortify-source.patch')
-rw-r--r--testing/vis/fortify-source.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/testing/vis/fortify-source.patch b/testing/vis/fortify-source.patch
new file mode 100644
index 00000000000..bb790c703d8
--- /dev/null
+++ b/testing/vis/fortify-source.patch
@@ -0,0 +1,16 @@
+-D_FORTIFY_SOURCE=2 is enable in gcc by default on alpine. See the
+010_all_default-fortify-source.patch patch in main/gcc. Disabling
+it here silences a bunch of compiler warnings.
+
+diff -upr vis-0.1.orig/config.mk vis-0.1/config.mk
+--- vis-0.1.orig/config.mk 2016-02-27 17:42:14.812754756 +0100
++++ vis-0.1/config.mk 2016-02-27 17:42:23.349390641 +0100
+@@ -64,7 +64,7 @@ STRIP ?= strip
+
+ # Hardening
+ ifeq (${CC},gcc)
+- CFLAGS += -fPIC -fstack-protector-all -D_FORTIFY_SOURCE=2
++ CFLAGS += -fPIC -fstack-protector-all
+ LDFLAGS += -z now -z relro -pie
+ else ifeq (${CC},clang)
+ CFLAGS += -fPIE -fstack-protector-all -D_FORTIFY_SOURCE=2