aboutsummaryrefslogtreecommitdiffstats
path: root/testing/w_scan
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-05-03 00:05:23 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-05-03 00:10:50 +0200
commit8c5f9fe8159674f21d06dd464d1e9f23d7c7fe51 (patch)
tree6e6a8123c8b4f061d5ab6a1b6a52fc5b48b94225 /testing/w_scan
parent81bbc283809eacabc30c50dcd7d06c13b2eb4477 (diff)
testing/w_scan: upgrade to 20170107
Also remove `musl-build-uint-fix.patch` and use sed(1) instead because otherwise the patch has to be updated with each new release.
Diffstat (limited to 'testing/w_scan')
-rw-r--r--testing/w_scan/APKBUILD31
-rw-r--r--testing/w_scan/musl-build-uint-fix.patch12
2 files changed, 17 insertions, 26 deletions
diff --git a/testing/w_scan/APKBUILD b/testing/w_scan/APKBUILD
index 42fd2970d1f..1c5c6b9d6ce 100644
--- a/testing/w_scan/APKBUILD
+++ b/testing/w_scan/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=w_scan
-pkgver=20161022
+pkgver=20170107
pkgrel=0
pkgdesc="Universal ATSC and DVB blind scanner"
url="http://wirbel.htpc-forum.de/w_scan/index_en.html"
@@ -10,14 +10,24 @@ license="GPL"
makedepends="linux-headers"
subpackages="$pkgname-doc"
source="http://wirbel.htpc-forum.de/$pkgname/$pkgname-$pkgver.tar.bz2
-musl-build-time-h-fix.patch
-musl-build-uint-fix.patch"
+ musl-build-time-h-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ sed 's/uint/unsigned int/' -i "$builddir"/version.h
+}
+
build() {
cd "$builddir"
- ./configure --prefix=/usr
- make || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
}
package() {
@@ -25,12 +35,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="57aa860b4c9e6aa480ca6eb0504bd4f5 w_scan-20161022.tar.bz2
-79d2970d162d91c9f0392e74725326fe musl-build-time-h-fix.patch
-633b01139ff767da94afa93bc3d386f8 musl-build-uint-fix.patch"
-sha256sums="2077af7f8b42b7af038e83abf0565f96f59461bbc5e14c4516b68f50b5c00d79 w_scan-20161022.tar.bz2
-09ea1ab87568682c71b047a75aa9f347e3c739eae5875db2142d706f9ba72d73 musl-build-time-h-fix.patch
-b2aa3ce57d88628d46febc6fcd66473fc6f58c8ffc47f13c7b22ad140051e4ff musl-build-uint-fix.patch"
-sha512sums="f0f91a0115612c03f4e3de536b416f32ce8242df9db7e65bd3f673973e5e00bbc763edfb27b286eaa44bef052fc3aaf8fbb1312b8dd103f0ff72f3417c33b042 w_scan-20161022.tar.bz2
-5514dd105c51b23728ea4d5d0e04604b2674e0686645b1434197a9cdaa98bf7cac3946baad6357478160ce1feb5d1a3a74b8c1897f846cfb04c0bb58d9ac8b1b musl-build-time-h-fix.patch
-eeaa1fb1961ece503582f5f3a81edbc0a131f49ce5f78e0a1119fff067338f3ba5052acbba2c54254be242a1ebd19a9ae0cea5c35da93727f53350a4f4a74008 musl-build-uint-fix.patch"
+sha512sums="c8e163b5e4897e2bc48596a1104974c79807432c423a3dd172e85c6ed6d4f9a4a471150ae7fe1b78fe570987e9fdee666a491700368c8499b03e9b13aa5cde6a w_scan-20170107.tar.bz2
+5514dd105c51b23728ea4d5d0e04604b2674e0686645b1434197a9cdaa98bf7cac3946baad6357478160ce1feb5d1a3a74b8c1897f846cfb04c0bb58d9ac8b1b musl-build-time-h-fix.patch"
diff --git a/testing/w_scan/musl-build-uint-fix.patch b/testing/w_scan/musl-build-uint-fix.patch
deleted file mode 100644
index 51b82cc0278..00000000000
--- a/testing/w_scan/musl-build-uint-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/version.h b/version.h
-index 16661b5..44c5ec7 100644
---- a/version.h
-+++ b/version.h
-@@ -1,6 +1,6 @@
- /* AUTOMATICALLY GENERATED - DO NOT EDIT MANUALLY */
- #ifndef W_SCAN_VERSION_H
- #define W_SCAN_VERSION_H
--uint version=20161022;
-+unsigned int version=20161022;
- #endif
-