aboutsummaryrefslogtreecommitdiffstats
path: root/testing/waybar/APKBUILD
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-07-28 13:53:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 08:17:57 -0300
commite0b2feaa92c4bf801d868c188dfe62c8b37c7cf2 (patch)
tree55f2e841aeb740fd50fbc8795db6d9c902290bd2 /testing/waybar/APKBUILD
parent5bace0b2b0e600a6f644bd0ea51f2027a19b0a91 (diff)
testing/waybar: new aport
Diffstat (limited to 'testing/waybar/APKBUILD')
-rw-r--r--testing/waybar/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/waybar/APKBUILD b/testing/waybar/APKBUILD
new file mode 100644
index 00000000000..b71bba1c40c
--- /dev/null
+++ b/testing/waybar/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Luca Weiss <luca@z3ntu.xyz>
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname="waybar"
+pkgver="0.7.1"
+pkgrel=0
+pkgdesc="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+url="https://github.com/Alexays/Waybar/"
+arch="all"
+license="MIT"
+depends="ttf-font-awesome"
+makedepends="meson gtkmm3-dev jsoncpp-dev spdlog-dev fmt-dev libinput-dev
+ libnl3-dev pulseaudio-dev libmpdclient-dev eudev-dev"
+source="Waybar-$pkgver.tar.gz::https://github.com/Alexays/Waybar/archive/$pkgver.tar.gz"
+options="!check" # No test suite
+builddir="$srcdir/Waybar-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="3e7b11a26e8bd76907a802f1025c075fe240ebcde53a01f4bb045946a13962c2f8892e8b11d3e8f1c96e22ef9c8491d159b9852c92f08a872064140221c88570 Waybar-0.7.1.tar.gz"